[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <aAuQjSzatuNoDDXL@Mac.home>
Date: Fri, 25 Apr 2025 06:39:25 -0700
From: Boqun Feng <boqun.feng@...il.com>
To: Alice Ryhl <aliceryhl@...gle.com>
Cc: Miguel Ojeda <ojeda@...nel.org>,
Andrew Morton <akpm@...ux-foundation.org>,
Alexander Viro <viro@...iv.linux.org.uk>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Gary Guo <gary@...yguo.net>,
Björn Roy Baron <bjorn3_gh@...tonmail.com>,
Benno Lossin <benno.lossin@...ton.me>,
Andreas Hindborg <a.hindborg@...nel.org>,
Trevor Gross <tmgross@...ch.edu>,
Danilo Krummrich <dakr@...nel.org>, rust-for-linux@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] uaccess: rust: add strncpy_from_user
On Fri, Apr 25, 2025 at 09:43:30AM +0000, Alice Ryhl wrote:
> On Thu, Apr 24, 2025 at 08:57:13AM -0700, Boqun Feng wrote:
> > On Thu, Apr 24, 2025 at 03:17:48PM +0000, Alice Ryhl wrote:
> > > This is needed for ioctls that operate on a user-provided string.
> > >
> > > It is somewhat unfortunate that strncpy_from_user does not nul-terminate
> > > the string when the end of `buf` is reached. This implies that we can't
> > > return a &CStr from the function, since the buffer may not always be
> > > nul-terminated.
> > >
> > > That said, we could add more convenient helpers on top that add a NUL
> > > byte in that case.
> > >
> > > This method isn't defined on UserSliceReader because it complicates the
> > > semantics. The UserSliceReader type also has its own maximum length, so
> > > we would have to limit the read by that length too.
> > >
> > > Signed-off-by: Alice Ryhl <aliceryhl@...gle.com>
> > > ---
> > > rust/kernel/uaccess.rs | 27 +++++++++++++++++++++++++++
> > > 1 file changed, 27 insertions(+)
> > >
> > > diff --git a/rust/kernel/uaccess.rs b/rust/kernel/uaccess.rs
> > > index 80a9782b1c6e98ed6eae308ade8551afa7adc188..1bd82045e81ea887008e30241bd6de27f096b639 100644
> > > --- a/rust/kernel/uaccess.rs
> > > +++ b/rust/kernel/uaccess.rs
> > > @@ -369,3 +369,30 @@ pub fn write<T: AsBytes>(&mut self, value: &T) -> Result {
> > > Ok(())
> > > }
> > > }
> > > +
> > > +/// Reads a nul-terminated string into `buf` and returns the length.
> > > +///
> > > +/// Fails with [`EFAULT`] if the read happens on a bad address. If the end of `buf` is reached,
> > > +/// then the buffer will not be nul-terminated.
> > > +#[inline]
> > > +pub fn strncpy_from_user(ptr: UserPtr, buf: &mut [u8]) -> Result<usize> {
> >
> > Sorry maybe there is an email I'm missing, but could you provide more
> > context of the usage?
> >
> > First the function name is a bit weird, because the 'n' in "strncpy"
> > means the parameters should have an 'n' (i.e. length) in it, but there
> > is none in the Rust version.
>
> There is a length! It's the length of `buf`. It's pretty normal that C
> methods with a pointer and length become a Rust method with a slice.
>
That's exactly the point, no need to reuse a name from C if we have
something better.
> The distinction between strcpy and strncpy in my eyes is that strcpy
> reads until you find a NUL byte, whereas strncpy reads until you find a
> NUL byte *or* you read a user-specified number of bytes. This method is
> in the latter category.
>
Then copy_from_user_until_nul()? Or cstrcpy_from_user()? We should have
a bit consistent naming on Rust side regardless how C names things IMO.
Regards,
Boqun
> > Also, we don't need to replicate the
> > semantics of C here, we could just do a strncpy_from_user(..., ..., len
> > - 1), where `len` is the len of the `buf`, and then we would always have
> > a nul-terminated string. But maybe I'm missing something from the usage
> > side, so this is not doable?
>
> Well, I guess that probably does make sense. I'll update this to always
> add a nul-terminator.
>
> Alice
Powered by blists - more mailing lists