[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250425083442.2390017-1-xin@zytor.com>
Date: Fri, 25 Apr 2025 01:34:23 -0700
From: "Xin Li (Intel)" <xin@...or.com>
To: linux-kernel@...r.kernel.org, kvm@...r.kernel.org,
linux-perf-users@...r.kernel.org, linux-hyperv@...r.kernel.org,
virtualization@...ts.linux.dev, linux-pm@...r.kernel.org,
linux-edac@...r.kernel.org, xen-devel@...ts.xenproject.org,
linux-acpi@...r.kernel.org, linux-hwmon@...r.kernel.org,
netdev@...r.kernel.org, platform-driver-x86@...r.kernel.org
Cc: tglx@...utronix.de, mingo@...hat.com, bp@...en8.de,
dave.hansen@...ux.intel.com, x86@...nel.org, hpa@...or.com,
acme@...nel.org, jgross@...e.com, andrew.cooper3@...rix.com,
peterz@...radead.org, namhyung@...nel.org, mark.rutland@....com,
alexander.shishkin@...ux.intel.com, jolsa@...nel.org,
irogers@...gle.com, adrian.hunter@...el.com, kan.liang@...ux.intel.com,
wei.liu@...nel.org, ajay.kaher@...adcom.com,
bcm-kernel-feedback-list@...adcom.com, tony.luck@...el.com,
pbonzini@...hat.com, vkuznets@...hat.com, seanjc@...gle.com,
luto@...nel.org, boris.ostrovsky@...cle.com, kys@...rosoft.com,
haiyangz@...rosoft.com, decui@...rosoft.com,
dapeng1.mi@...ux.intel.com
Subject: [PATCH v3 00/14] MSR code cleanup part one
This patch set is the first part of the patch set:
MSR refactor with new MSR instructions support
@ https://lore.kernel.org/lkml/20250422082216.1954310-1-xin@zytor.com/T/#m5a34be7d4ed55f0baca965cb65452a08e9ad7c8a
It's getting *WAY* too big, and whether to zap the pv_ops MSR APIs is
still under argument. Dave Hansen suggested to focus on rename stuff
first, most of which he acked.
Jürgen Groß also gave his RBs to most of the Xen MSR cleanup patches.
So here comes the first MSR cleanup patch set with version 3.
This patch series is based on:
git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git x86/msr
Xin Li (Intel) (14):
x86/msr: Move rdtsc{,_ordered}() to <asm/tsc.h>
x86/msr: Remove rdpmc()
x86/msr: Rename rdpmcl() to rdpmc()
x86/msr: Convert the rdpmc() macro into an always inline function
x86/msr: Return u64 consistently in Xen PMC read functions
x86/msr: Convert __wrmsr() uses to native_wrmsr{,q}() uses
x86/msr: Add the native_rdmsrq() helper
x86/msr: Convert __rdmsr() uses to native_rdmsrq() uses
x86/xen/msr: Remove calling native_{read,write}_msr{,_safe}() in
pmu_msr_{read,write}()
x86/xen/msr: Remove pmu_msr_{read,write}()
x86/xen/msr: Remove the error pointer argument from set_seg()
x86/pvops/msr: refactor pv_cpu_ops.write_msr{,_safe}()
x86/msr: Replace wrmsr(msr, low, 0) with wrmsrq(msr, low)
x86/msr: Change the function type of native_read_msr_safe()
arch/x86/coco/sev/core.c | 2 +-
arch/x86/events/amd/brs.c | 4 +-
arch/x86/events/amd/uncore.c | 2 +-
arch/x86/events/core.c | 2 +-
arch/x86/events/intel/core.c | 4 +-
arch/x86/events/intel/ds.c | 2 +-
arch/x86/events/msr.c | 3 +
arch/x86/events/perf_event.h | 1 +
arch/x86/events/probe.c | 2 +
arch/x86/hyperv/hv_apic.c | 6 +-
arch/x86/hyperv/hv_vtl.c | 4 +-
arch/x86/hyperv/ivm.c | 3 +-
arch/x86/include/asm/apic.h | 4 +-
arch/x86/include/asm/fred.h | 1 +
arch/x86/include/asm/microcode.h | 2 +
arch/x86/include/asm/mshyperv.h | 3 +-
arch/x86/include/asm/msr.h | 130 +++++-------------
arch/x86/include/asm/paravirt.h | 57 ++++----
arch/x86/include/asm/paravirt_types.h | 10 +-
arch/x86/include/asm/suspend_32.h | 1 +
arch/x86/include/asm/suspend_64.h | 1 +
arch/x86/include/asm/switch_to.h | 4 +-
arch/x86/include/asm/tsc.h | 76 +++++++++-
arch/x86/kernel/cpu/amd.c | 2 +-
arch/x86/kernel/cpu/common.c | 10 +-
arch/x86/kernel/cpu/mce/core.c | 6 +-
arch/x86/kernel/cpu/resctrl/pseudo_lock.c | 25 ++--
arch/x86/kernel/cpu/resctrl/rdtgroup.c | 2 +-
arch/x86/kernel/cpu/umwait.c | 4 +-
arch/x86/kernel/fpu/xstate.h | 1 +
arch/x86/kernel/hpet.c | 1 +
arch/x86/kernel/kvm.c | 2 +-
arch/x86/kernel/kvmclock.c | 2 +-
arch/x86/kernel/process_64.c | 1 +
arch/x86/kernel/trace_clock.c | 2 +-
arch/x86/kernel/tsc_sync.c | 1 +
arch/x86/kvm/svm/svm.c | 34 ++---
arch/x86/kvm/vmx/vmx.c | 4 +-
arch/x86/lib/kaslr.c | 2 +-
arch/x86/mm/mem_encrypt_identity.c | 5 +-
arch/x86/realmode/init.c | 1 +
arch/x86/xen/enlighten_pv.c | 58 ++++----
arch/x86/xen/pmu.c | 69 +++-------
arch/x86/xen/xen-ops.h | 5 +-
drivers/acpi/processor_perflib.c | 1 +
drivers/acpi/processor_throttling.c | 3 +-
drivers/cpufreq/amd-pstate-ut.c | 2 +
drivers/hwmon/hwmon-vid.c | 4 +
drivers/net/vmxnet3/vmxnet3_drv.c | 4 +
drivers/platform/x86/intel/pmc/cnp.c | 1 +
.../intel/speed_select_if/isst_if_common.c | 1 +
drivers/platform/x86/intel/turbo_max_3.c | 1 +
52 files changed, 284 insertions(+), 294 deletions(-)
base-commit: a5447e92e169dafaf02fd653500105c7186d7128
--
2.49.0
Powered by blists - more mailing lists