[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250428171608.21111-3-nifan.cxl@gmail.com>
Date: Mon, 28 Apr 2025 10:11:43 -0700
From: nifan.cxl@...il.com
To: muchun.song@...ux.dev,
willy@...radead.org
Cc: mcgrof@...nel.org,
a.manzanares@...sung.com,
dave@...olabs.net,
akpm@...ux-foundation.org,
david@...hat.com,
linux-mm@...ck.org,
linux-kernel@...r.kernel.org,
Fan Ni <fan.ni@...sung.com>
Subject: [PATCH v3 0/4] mm/hugetlb: Let unmap_hugepage_range() and
From: Fan Ni <fan.ni@...sung.com>
Changes compared to v2,
Patch 1:
1) Update the commit log subject;
2) Use &folio->page instead of folio_page(folio) in unmap_ref_private()
when calling unmap_hugepage_range();
Patch 2:
1) Update the declaration of unmap_hugepage_range() in hugetlb.h;
2) Use &folio->page instead of folio_page(folio) in unmap_hugepage_range()
when calling __unmap_hugepage_range();
Patch 3:
1) Update the declaration of __unmap_hugepage_range() in hugetlb.h;
2) Rename ref_folio to folio;
3) compare folio instead of page in __unmap_hugepage_range() when folio is
provided when calling __unmap_hugepage_range();
Patch 4:
1) Pass folio size instead of huge_page_size() when calling
tlb_remove_page_size() by Matthew;
2) Update the processing inside __unmap_hugepage_range() when folio
is provided as sugguested by David Hildenbrand;
3) Since there is some functional change in this patch, we do not pick up the
tags;
v2:
https://lore.kernel.org/linux-mm/20250418170834.248318-2-nifan.cxl@gmail.com
Fan Ni (4):
mm/hugetlb: Pass folio instead of page to unmap_ref_private()
mm/hugetlb: Refactor unmap_hugepage_range() to take folio instead of
page
mm/hugetlb: Refactor __unmap_hugepage_range() to take folio instead of
page
mm/hugetlb: Convert use of struct page to folio in
__unmap_hugepage_range()
include/linux/hugetlb.h | 8 ++++----
mm/hugetlb.c | 39 +++++++++++++++++++++------------------
2 files changed, 25 insertions(+), 22 deletions(-)
--
2.47.2
Powered by blists - more mailing lists