[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <86a580k3fu.wl-maz@kernel.org>
Date: Mon, 28 Apr 2025 11:04:05 +0100
From: Marc Zyngier <maz@...nel.org>
To: "Seongsu Park" <sgsu.park@...sung.com>
Cc: "'Anshuman Khandual'" <anshuman.khandual@....com>,
<will@...nel.org>,
<catalin.marinas@....com>,
<suzuki.poulose@....com>,
<joey.gouly@....com>,
<oliver.upton@...ux.dev>,
<linux-arm-kernel@...ts.infradead.org>,
<kvmarm@...ts.linux.dev>,
<linux-kernel@...r.kernel.org>,
<cpgs@...sung.com>
Subject: Re: [PATCH] arm64: kvm: Replace ternary flags with str_on_off() helper
On Mon, 28 Apr 2025 08:11:59 +0100,
"Seongsu Park" <sgsu.park@...sung.com> wrote:
> > On 4/15/25 06:54, Seongsu Park wrote:
> > > Replace repetitive ternary expressions with the str_on_off() helper
> > > function. This change improves code readability and ensures
> > > consistency in tracepoint string formatting
> > >
> > > Signed-off-by: Seongsu Park <sgsu.park@...sung.com>
> > > ---
> > > arch/arm64/kvm/trace_arm.h | 6 +++---
> > > 1 file changed, 3 insertions(+), 3 deletions(-)
> > >
> > > diff --git a/arch/arm64/kvm/trace_arm.h b/arch/arm64/kvm/trace_arm.h
> > > index c18c1a95831e..9c60f6465c78 100644
> > > --- a/arch/arm64/kvm/trace_arm.h
> > > +++ b/arch/arm64/kvm/trace_arm.h
> > > @@ -176,7 +176,7 @@ TRACE_EVENT(kvm_set_way_flush,
> > > ),
> > >
> > > TP_printk("S/W flush at 0x%016lx (cache %s)",
> > > - __entry->vcpu_pc, __entry->cache ? "on" : "off")
> > > + __entry->vcpu_pc, str_on_off(__entry->cache))
> > > );
> > >
> > > TRACE_EVENT(kvm_toggle_cache,
> > > @@ -196,8 +196,8 @@ TRACE_EVENT(kvm_toggle_cache,
> > > ),
> > >
> > > TP_printk("VM op at 0x%016lx (cache was %s, now %s)",
> > > - __entry->vcpu_pc, __entry->was ? "on" : "off",
> > > - __entry->now ? "on" : "off")
> > > + __entry->vcpu_pc, str_on_off(__entry->was),
> > > + str_on_off(__entry->now))
> > > );
> > >
> > > /*
> >
> > Reviewed-by: Anshuman Khandual <anshuman.khandual@....com>
>
> Dear Anshuman,
>
> Do you have any feedback?
> If you have, please let me know.
> I think this patch is appropriate.
There isn't much to add. This patch looks reasonable, but it also
doesn't warrant being merged immediately (it is purely cosmetic).
Once I start queuing patches for 6.16, I'll probably add it to the
mix.
Thanks,
M.
--
Without deviation from the norm, progress is not possible.
Powered by blists - more mailing lists