[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <udqm2qkw3yrewmovua54twfzbsfduojc5f5uoj4nptxldpbbr5@75bb2pldwq7f>
Date: Tue, 29 Apr 2025 16:32:57 +0200
From: Angelo Dureghello <adureghello@...libre.com>
To: Andy Shevchenko <andy@...nel.org>
Cc: Nuno Sa <nuno.sa@...log.com>, Lars-Peter Clausen <lars@...afoo.de>,
Michael Hennerich <Michael.Hennerich@...log.com>, Jonathan Cameron <jic23@...nel.org>,
David Lechner <dlechner@...libre.com>, linux-iio@...r.kernel.org, linux-kernel@...r.kernel.org,
Jonathan Cameron <Jonathan.Cameron@...wei.com>
Subject: Re: [PATCH v2 2/2] iio: dac: adi-axi-dac: use unique bus free check
Hi Andy,
sorry, seen this message now only, for some reason sometimes your emails
goes to the spam. Now i marked all as "not spam", let's see.
On 09.04.2025 19:51, Andy Shevchenko wrote:
> On Wed, Apr 09, 2025 at 11:16:55AM +0200, Angelo Dureghello wrote:
> > From: Angelo Dureghello <adureghello@...libre.com>
> >
> > Use a unique function for the bus free check by polling, to reduce
> > duplicated code. An error is always thrown in case of timeout.
>
> ...
>
> > +static int axi_dac_wait_bus_free(struct axi_dac_state *st)
> > +{
> > + u32 val;
> > + int ret;
> > +
> > + ret = regmap_read_poll_timeout(st->regmap, AXI_DAC_UI_STATUS_REG, val,
> > + FIELD_GET(AXI_DAC_UI_STATUS_IF_BUSY, val) == -1, 10,
> > + 100 * KILO);
>
> Same comment as in the previous patch. Okay, it seems more than in the single
> case. Perhaps to change that as well here?
>
for my personal taste would not use more specific named defines here,
would not change this, in case we can send a separate patch to fix
them all.
> > + if (ret == -ETIMEDOUT)
> > + dev_err(st->dev, "AXI bus timeout\n");
>
> Why do you need this? The error code will go to the user space at the end? If
> yes, it will be enough to have it printed there, no?
>
This warning means something very bad happen at AXI level. I never seen
this warning issued, but it may help to debug AXI/HDL issues, would not
remove it.
> > + return ret;
> > +}
>
>
> --
> With Best Regards,
> Andy Shevchenko
>
>
Regards,
angelo
Powered by blists - more mailing lists