[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <5c18acfc-7893-4731-9292-dc69a7acdff2@app.fastmail.com>
Date: Tue, 29 Apr 2025 17:51:05 +0200
From: "Arnd Bergmann" <arnd@...db.de>
To: "FUJITA Tomonori" <fujita.tomonori@...il.com>,
"Andreas Hindborg" <a.hindborg@...nel.org>
Cc: rust-for-linux@...r.kernel.org, "Gary Guo" <gary@...yguo.net>,
"Alice Ryhl" <aliceryhl@...gle.com>, me@...enk.dev,
daniel.almeida@...labora.com, linux-kernel@...r.kernel.org,
Netdev <netdev@...r.kernel.org>, "Andrew Lunn" <andrew@...n.ch>,
"Heiner Kallweit" <hkallweit1@...il.com>,
"Trevor Gross" <tmgross@...ch.edu>, "Miguel Ojeda" <ojeda@...nel.org>,
"Alex Gaynor" <alex.gaynor@...il.com>,
Björn Roy Baron <bjorn3_gh@...tonmail.com>,
"Benno Lossin" <benno.lossin@...ton.me>,
"Andreas Hindborg" <a.hindborg@...sung.com>,
"Anna-Maria Gleixner" <anna-maria@...utronix.de>,
"Frederic Weisbecker" <frederic@...nel.org>,
"Thomas Gleixner" <tglx@...utronix.de>,
"John Stultz" <jstultz@...gle.com>, "Stephen Boyd" <sboyd@...nel.org>,
"Ingo Molnar" <mingo@...hat.com>,
"Peter Zijlstra" <peterz@...radead.org>,
"Juri Lelli" <juri.lelli@...hat.com>,
"Vincent Guittot" <vincent.guittot@...aro.org>,
"Dietmar Eggemann" <dietmar.eggemann@....com>,
"Steven Rostedt" <rostedt@...dmis.org>,
"Benjamin Segall" <bsegall@...gle.com>, "Mel Gorman" <mgorman@...e.de>,
"Valentin Schneider" <vschneid@...hat.com>, tgunders@...hat.com,
david.laight.linux@...il.com, "Boqun Feng" <boqun.feng@...il.com>,
"Paolo Bonzini" <pbonzini@...hat.com>,
"Jocelyn Falempe" <jfalempe@...hat.com>,
"Russell King" <linux@...linux.org.uk>,
"Christian Schrefl" <chrisi.schrefl@...il.com>,
"Linus Walleij" <linus.walleij@...aro.org>
Subject: Re: [PATCH v15 5/6] rust: time: Add wrapper for fsleep() function
On Tue, Apr 29, 2025, at 15:17, FUJITA Tomonori wrote:
> On Mon, 28 Apr 2025 20:16:47 +0200 Andreas Hindborg <a.hindborg@...nel.org> wrote:
> /// Return the number of milliseconds in the [`Delta`].
> #[inline]
> - pub const fn as_millis(self) -> i64 {
> - self.as_nanos() / NSEC_PER_MSEC
> + pub fn as_millis(self) -> i64 {
> + math64::div64_s64(self.as_nanos(), NSEC_PER_MSEC)
> }
> }
I think simply calling ktime_to_ms()/ktime_to_us() should result
in reasonably efficient code, since the C version is able to
convert the constant divisor into a multiply/shift operation.
div64_s64() itself is never optimized for constant arguments since
the C version is not inline, if any driver needs those, this is
better done open-coded so hopefully it gets caught in review
when this is called in a fast path.
Arnd
Powered by blists - more mailing lists