lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <549c15f4-8bdf-4823-ae2d-95d2861325d3@linux.intel.com>
Date: Tue, 29 Apr 2025 11:37:38 +0800
From: "Abdul Rahim, Faizal" <faizal.abdul.rahim@...ux.intel.com>
To: "Ruinskiy, Dima" <dima.ruinskiy@...el.com>,
 Tony Nguyen <anthony.l.nguyen@...el.com>,
 Przemek Kitszel <przemyslaw.kitszel@...el.com>,
 Andrew Lunn <andrew+netdev@...n.ch>, "David S . Miller"
 <davem@...emloft.net>, Eric Dumazet <edumazet@...gle.com>,
 Jakub Kicinski <kuba@...nel.org>, Paolo Abeni <pabeni@...hat.com>,
 Vladimir Oltean <vladimir.oltean@....com>
Cc: intel-wired-lan@...ts.osuosl.org, netdev@...r.kernel.org,
 linux-kernel@...r.kernel.org, Chwee-Lin Choong <chwee.lin.choong@...el.com>
Subject: Re: [Intel-wired-lan] [PATCH iwl-next v1 2/8] igc: add TXDCTL prefix
 to related macros



On 28/4/2025 2:57 pm, Ruinskiy, Dima wrote:
> On 28/04/2025 9:02, Faizal Rahim wrote:
>> Rename macros to include the TXDCTL_ prefix for consistency and clarity.
>> This aligns naming with the register they configure and improves code
>> readability.
>>
>> Signed-off-by: Faizal Rahim <faizal.abdul.rahim@...ux.intel.com>
>> ---
>>   drivers/net/ethernet/intel/igc/igc.h      | 6 +++---
>>   drivers/net/ethernet/intel/igc/igc_main.c | 6 +++---
>>   2 files changed, 6 insertions(+), 6 deletions(-)
>>
>> diff --git a/drivers/net/ethernet/intel/igc/igc.h b/drivers/net/ethernet/ 
>> intel/igc/igc.h
>> index e9d180eac015..bc37cc8deefb 100644
>> --- a/drivers/net/ethernet/intel/igc/igc.h
>> +++ b/drivers/net/ethernet/intel/igc/igc.h
>> @@ -487,10 +487,10 @@ static inline u32 igc_rss_type(const union 
>> igc_adv_rx_desc *rx_desc)
>>    */
>>   #define IGC_RX_PTHRESH            8
>>   #define IGC_RX_HTHRESH            8
>> -#define IGC_TX_PTHRESH            8
>> -#define IGC_TX_HTHRESH            1
>> +#define IGC_TXDCTL_PTHRESH        8
>> +#define IGC_TXDCTL_HTHRESH        1
>>   #define IGC_RX_WTHRESH            4
>> -#define IGC_TX_WTHRESH            16
>> +#define IGC_TXDCTL_WTHRESH        16
>>   /* Additional Transmit Descriptor Control definitions */
>>   /* Ena specific Tx Queue */
>> diff --git a/drivers/net/ethernet/intel/igc/igc_main.c b/drivers/net/ 
>> ethernet/intel/igc/igc_main.c
>> index 27575a1e1777..725c8f0b9f3d 100644
>> --- a/drivers/net/ethernet/intel/igc/igc_main.c
>> +++ b/drivers/net/ethernet/intel/igc/igc_main.c
>> @@ -749,9 +749,9 @@ static void igc_configure_tx_ring(struct igc_adapter 
>> *adapter,
>>       wr32(IGC_TDH(reg_idx), 0);
>>       writel(0, ring->tail);
>> -    txdctl |= IGC_TX_PTHRESH;
>> -    txdctl |= IGC_TX_HTHRESH << 8;
>> -    txdctl |= IGC_TX_WTHRESH << 16;
>> +    txdctl |= IGC_TXDCTL_PTHRESH;
>> +    txdctl |= IGC_TXDCTL_HTHRESH << 8;
>> +    txdctl |= IGC_TXDCTL_WTHRESH << 16;
>>       txdctl |= IGC_TXDCTL_QUEUE_ENABLE;
>>       wr32(IGC_TXDCTL(reg_idx), txdctl);
> 
> If you do this, I think you should apply the same change to the RXDCTL 
> macros that are right next to the TXDCTL ones. Otherwise you are trading 
> one inconsistency for another. :)

Will update


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ