[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250430145920.3748738-1-ryan.roberts@arm.com>
Date: Wed, 30 Apr 2025 15:59:13 +0100
From: Ryan Roberts <ryan.roberts@....com>
To: Andrew Morton <akpm@...ux-foundation.org>,
"Matthew Wilcox (Oracle)" <willy@...radead.org>,
Alexander Viro <viro@...iv.linux.org.uk>,
Christian Brauner <brauner@...nel.org>,
Jan Kara <jack@...e.cz>,
David Hildenbrand <david@...hat.com>,
Dave Chinner <david@...morbit.com>,
Catalin Marinas <catalin.marinas@....com>,
Will Deacon <will@...nel.org>,
Kalesh Singh <kaleshsingh@...gle.com>,
Zi Yan <ziy@...dia.com>
Cc: Ryan Roberts <ryan.roberts@....com>,
linux-arm-kernel@...ts.infradead.org,
linux-kernel@...r.kernel.org,
linux-fsdevel@...r.kernel.org,
linux-mm@...ck.org
Subject: [RFC PATCH v4 0/5] Readahead tweaks for larger folios
Hi All,
This RFC series adds some tweaks to readahead so that it does a better job of
ramping up folio sizes as readahead extends further into the file. And it
additionally special-cases executable mappings to allow the arch to request a
preferred folio size for text.
Previous versions of the series focussed on the latter part only (large folios
for text). See [3]. But after discussion with Matthew Wilcox last week, we
decided that we should really be fixing some of the unintended behaviours in how
a folio size is selected in general before special-casing for text. As a result
patches 1-4 make folio size selection behave more sanely, then patch 5
introduces large folios for text. Patch 5 depends on patch 1, but does not
depend on patches 2-4.
---
I'm leaving this marked as RFC for now as I intend to do more testing, and
haven't yet updated the benchmark results in patch 5 (although I expect them to
be similar).
Applies on top of Monday's mm-unstable (b18dec6a6ad3) and passes all mm
kselftests.
Changes since v3 [3]
====================
- Added patchs 1-4 to do better job of ramping up folio order
- In patch 5:
- Confine readahead blocks to vma boundaries (per Kalesh)
- Rename arch_exec_folio_order() to exec_folio_order() (per Matthew)
- exec_folio_order() now returns unsigned int and defaults to order-0
(per Matthew)
- readahead size is honoured (including when disabled)
Changes since v2 [2]
====================
- Rename arch_wants_exec_folio_order() to arch_exec_folio_order() (per Andrew)
- Fixed some typos (per Andrew)
Changes since v1 [1]
====================
- Remove "void" from arch_wants_exec_folio_order() macro args list
[1] https://lore.kernel.org/linux-mm/20240111154106.3692206-1-ryan.roberts@arm.com/
[2] https://lore.kernel.org/all/20240215154059.2863126-1-ryan.roberts@arm.com/
[3] https://lore.kernel.org/linux-mm/20250327160700.1147155-1-ryan.roberts@arm.com/
Thanks,
Ryan
Ryan Roberts (5):
mm/readahead: Honour new_order in page_cache_ra_order()
mm/readahead: Terminate async readahead on natural boundary
mm/readahead: Make space in struct file_ra_state
mm/readahead: Store folio order in struct file_ra_state
mm/filemap: Allow arch to request folio size for exec memory
arch/arm64/include/asm/pgtable.h | 8 +++++
include/linux/fs.h | 4 ++-
include/linux/pgtable.h | 11 +++++++
mm/filemap.c | 55 ++++++++++++++++++++++++--------
mm/internal.h | 3 +-
mm/readahead.c | 27 +++++++++-------
6 files changed, 81 insertions(+), 27 deletions(-)
--
2.43.0
Powered by blists - more mailing lists