[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250430182300.122896-1-chelsyratnawat2001@gmail.com>
Date: Wed, 30 Apr 2025 11:23:00 -0700
From: Chelsy Ratnawat <chelsyratnawat2001@...il.com>
To: jikos@...nel.org,
jic23@...nel.org,
srinivas.pandruvada@...ux.intel.com,
bentiss@...nel.org
Cc: linux-input@...r.kernel.org,
linux-iio@...r.kernel.org,
linux-kernel@...r.kernel.org,
Chelsy Ratnawat <chelsyratnawat2001@...il.com>
Subject: [PATCH] HID: sensor-hub: Fix typo and improve documentation for sensor_hub_remove_callback()
Fixed a typo in "registered" and improved grammar for better readability
and consistency with kernel-doc standards. No functional changes.
Signed-off-by: Chelsy Ratnawat <chelsyratnawat2001@...il.com>
---
include/linux/hid-sensor-hub.h | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/include/linux/hid-sensor-hub.h b/include/linux/hid-sensor-hub.h
index c27329e2a5ad..5d2ac79429d4 100644
--- a/include/linux/hid-sensor-hub.h
+++ b/include/linux/hid-sensor-hub.h
@@ -130,10 +130,11 @@ int sensor_hub_register_callback(struct hid_sensor_hub_device *hsdev,
/**
* sensor_hub_remove_callback() - Remove client callbacks
* @hsdev: Hub device instance.
-* @usage_id: Usage id of the client (E.g. 0x200076 for Gyro).
+* @usage_id: Usage id of the client (e.g. 0x200076 for Gyro).
*
-* If there is a callback registred, this call will remove that
-* callbacks, so that it will stop data and event notifications.
+* Removes a previously registered callback for the given usage ID.
+* Once removed, the client will no longer receive data or event
+* notifications.
*/
int sensor_hub_remove_callback(struct hid_sensor_hub_device *hsdev,
u32 usage_id);
--
2.43.5
Powered by blists - more mailing lists