[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <BN9PR11MB527651D1ED8E6CA4677FD7678C88A@BN9PR11MB5276.namprd11.prod.outlook.com>
Date: Wed, 7 May 2025 07:25:41 +0000
From: "Tian, Kevin" <kevin.tian@...el.com>
To: Nicolin Chen <nicolinc@...dia.com>, "jgg@...dia.com" <jgg@...dia.com>
CC: Vasant Hegde <vasant.hegde@....com>, "corbet@....net" <corbet@....net>,
"will@...nel.org" <will@...nel.org>, "bagasdotme@...il.com"
<bagasdotme@...il.com>, "robin.murphy@....com" <robin.murphy@....com>,
"joro@...tes.org" <joro@...tes.org>, "thierry.reding@...il.com"
<thierry.reding@...il.com>, "vdumpa@...dia.com" <vdumpa@...dia.com>,
"jonathanh@...dia.com" <jonathanh@...dia.com>, "shuah@...nel.org"
<shuah@...nel.org>, "jsnitsel@...hat.com" <jsnitsel@...hat.com>,
"nathan@...nel.org" <nathan@...nel.org>, "peterz@...radead.org"
<peterz@...radead.org>, "Liu, Yi L" <yi.l.liu@...el.com>,
"mshavit@...gle.com" <mshavit@...gle.com>, "praan@...gle.com"
<praan@...gle.com>, "zhangzekun11@...wei.com" <zhangzekun11@...wei.com>,
"iommu@...ts.linux.dev" <iommu@...ts.linux.dev>, "linux-doc@...r.kernel.org"
<linux-doc@...r.kernel.org>, "linux-kernel@...r.kernel.org"
<linux-kernel@...r.kernel.org>, "linux-arm-kernel@...ts.infradead.org"
<linux-arm-kernel@...ts.infradead.org>, "linux-tegra@...r.kernel.org"
<linux-tegra@...r.kernel.org>, "linux-kselftest@...r.kernel.org"
<linux-kselftest@...r.kernel.org>, "patches@...ts.linux.dev"
<patches@...ts.linux.dev>, "mochs@...dia.com" <mochs@...dia.com>,
"alok.a.tiwari@...cle.com" <alok.a.tiwari@...cle.com>, Suravee Suthikulpanit
<suravee.suthikulpanit@....com>
Subject: RE: [PATCH v2 10/22] iommufd/viommmu: Add IOMMUFD_CMD_VCMDQ_ALLOC
ioctl
> From: Nicolin Chen <nicolinc@...dia.com>
> Sent: Wednesday, May 7, 2025 4:13 AM
>
> On Tue, May 06, 2025 at 09:25:59AM +0000, Tian, Kevin wrote:
> > > From: Nicolin Chen <nicolinc@...dia.com>
> > > Sent: Wednesday, April 30, 2025 1:15 AM
> > >
> > > On Tue, Apr 29, 2025 at 03:52:48PM +0530, Vasant Hegde wrote:
> > > > On 4/29/2025 12:15 PM, Nicolin Chen wrote:
> > > > > On Tue, Apr 29, 2025 at 11:04:06AM +0530, Vasant Hegde wrote:
> > > > >
> > > > > Will the hardware replace the physical device ID in the event with
> > > > > the virtual device ID when injecting the event to a guest event/PPR
> > > > > queue?
> > > > > If so, yea, I think you can define them separately using the> vCMDQ
> > > > infrastructures:
> > > > > - IOMMU_VCMDQ_TYPE_AMD_VIOMMU_CMDBUF
> > > > > - IOMMU_VCMDQ_TYPE_AMD_VIOMMU_EVENTLOG
> > > > > - IOMMU_VCMDQ_TYPE_AMD_VIOMMU_PPRLOG
> > > > > (@Kevin @Jason Hmm, in this case we might want to revert the
> naming
> > > > > "vCMDQ" back to "vQEUEUE", once Vasant confirms.)
> > >
> > > I think I should rename IOMMUFD_OBJ_VCMDQ back to
> > > IOMMUFD_OBJ_VQUEUE
> > > since the same object fits three types of queue now in the AMD case.
> > >
> > > Or any better naming suggestion?
> > >
> >
> > What about IOMMUFD_OBJ_HQUEUE to differentiate from other
> > pure software queue structs? 'H" stands for direct hw access to
> > the queue object.
>
> I think it make some sense. There has been a concern of mine that
> some day we might need vQUEUE to deal with some non-HW-acced case,
> given "vQUEUE" is named much wider than what it actually supports.
>
> Also, vEVENTQ and FAULT_QUEUE fit into the "QUEUE" category too..
>
> Though "hQUEUE" would break the naming pattern that we have,
what is the naming pattern here?
maybe
> we could try something like: "HW_QUEUE", "DIRECT_QUEUE", or so?
HW_QUEUE is OK to me.
>
> Jason, do you have a better idea?
>
> Thanks
> Nicolin
Powered by blists - more mailing lists