[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <aByA1wael6H4tMo8@google.com>
Date: Thu, 8 May 2025 10:00:55 +0000
From: Matt Bobrowski <mattbobrowski@...gle.com>
To: Viktor Malik <vmalik@...hat.com>
Cc: bpf@...r.kernel.org, Alexei Starovoitov <ast@...nel.org>,
Daniel Borkmann <daniel@...earbox.net>,
Andrii Nakryiko <andrii@...nel.org>,
Martin KaFai Lau <martin.lau@...ux.dev>,
Eduard Zingerman <eddyz87@...il.com>, Song Liu <song@...nel.org>,
Yonghong Song <yonghong.song@...ux.dev>,
John Fastabend <john.fastabend@...il.com>,
KP Singh <kpsingh@...nel.org>, Stanislav Fomichev <sdf@...ichev.me>,
Hao Luo <haoluo@...gle.com>, Jiri Olsa <jolsa@...nel.org>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH bpf-next v4 2/4] uaccess: Define pagefault lock guard
On Wed, May 07, 2025 at 08:40:37AM +0200, Viktor Malik wrote:
> Define a pagefault lock guard which allows to simplify functions that
> need to disable page faults.
>
> Signed-off-by: Viktor Malik <vmalik@...hat.com>
> ---
> include/linux/uaccess.h | 2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git a/include/linux/uaccess.h b/include/linux/uaccess.h
> index 7c06f4795670..1beb5b395d81 100644
> --- a/include/linux/uaccess.h
> +++ b/include/linux/uaccess.h
> @@ -296,6 +296,8 @@ static inline bool pagefault_disabled(void)
> */
> #define faulthandler_disabled() (pagefault_disabled() || in_atomic())
>
> +DEFINE_LOCK_GUARD_0(pagefault, pagefault_disable(), pagefault_enable())
I can't help but mention that naming this scope-based cleanup helper
`pagefault` just seems overly ambiguous. That's just me though...
Powered by blists - more mailing lists