lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <9ee1bdcf-efc5-4edc-9693-bc0f35ca137e@nvidia.com>
Date: Wed, 14 May 2025 10:00:52 +0300
From: Mark Bloch <mbloch@...dia.com>
To: Chen Ni <nichen@...as.ac.cn>, saeedm@...dia.com, leon@...nel.org,
 tariqt@...dia.com, andrew+netdev@...n.ch, davem@...emloft.net,
 edumazet@...gle.com, kuba@...nel.org, pabeni@...hat.com
Cc: netdev@...r.kernel.org, linux-rdma@...r.kernel.org,
 linux-kernel@...r.kernel.org
Subject: Re: [PATCH] net/mlx5: Use to_delayed_work()



On 14/05/2025 9:34, Chen Ni wrote:
> Use to_delayed_work() instead of open-coding it.
> 
> Signed-off-by: Chen Ni <nichen@...as.ac.cn>
> ---
>  drivers/net/ethernet/mellanox/mlx5/core/cmd.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/drivers/net/ethernet/mellanox/mlx5/core/cmd.c b/drivers/net/ethernet/mellanox/mlx5/core/cmd.c
> index e53dbdc0a7a1..b1aeea7c4a91 100644
> --- a/drivers/net/ethernet/mellanox/mlx5/core/cmd.c
> +++ b/drivers/net/ethernet/mellanox/mlx5/core/cmd.c
> @@ -927,8 +927,7 @@ static void mlx5_cmd_comp_handler(struct mlx5_core_dev *dev, u64 vec, bool force
>  
>  static void cb_timeout_handler(struct work_struct *work)
>  {
> -	struct delayed_work *dwork = container_of(work, struct delayed_work,
> -						  work);
> +	struct delayed_work *dwork = to_delayed_work(work);
>  	struct mlx5_cmd_work_ent *ent = container_of(dwork,
>  						     struct mlx5_cmd_work_ent,
>  						     cb_timeout_work);

Please specify the target tree in your future submissions just
as you did with your Prestera patch. For the change itself:

Acked-by: Mark Bloch <mbloch@...dia.com>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ