[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250518175832.77b8d670@jic23-huawei>
Date: Sun, 18 May 2025 17:58:32 +0100
From: Jonathan Cameron <jic23@...nel.org>
To: Andy Shevchenko <andy@...nel.org>
Cc: Jonathan Santos <Jonathan.Santos@...log.com>, linux-iio@...r.kernel.org,
devicetree@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-gpio@...r.kernel.org, nuno.sa@...log.com,
Michael.Hennerich@...log.com, marcelo.schmitt@...log.com, robh@...nel.org,
krzk+dt@...nel.org, conor+dt@...nel.org, marcelo.schmitt1@...il.com,
linus.walleij@...aro.org, brgl@...ev.pl, lgirdwood@...il.com,
broonie@...nel.org, jonath4nns@...il.com, dlechner@...libre.com
Subject: Re: [PATCH v8 08/11] iio: adc: ad7768-1: add support for
Synchronization over SPI
On Fri, 16 May 2025 12:29:02 +0300
Andy Shevchenko <andy@...nel.org> wrote:
> On Thu, May 15, 2025 at 06:13:56PM -0300, Jonathan Santos wrote:
> > The synchronization method using GPIO requires the generated pulse to be
> > truly synchronous with the base MCLK signal. When it is not possible to
> > do that in hardware, the datasheet recommends using synchronization over
> > SPI, where the generated pulse is already synchronous with MCLK. This
> > requires the SYNC_OUT pin to be connected to the SYNC_IN pin.
> >
> > Use trigger-sources property to enable device synchronization over SPI
> > and multi-device synchronization while replacing sync-in-gpios property.
Given some discussion in here I'll not (yet) pick up this series.
It's almost certainly just missed the coming merge window anyway so
we have time.
>
> ...
>
> > +static int ad7768_trigger_sources_get_sync(struct device *dev,
> > + struct ad7768_state *st)
> > +{
> > + struct fwnode_reference_args args;
> > + struct fwnode_handle *fwnode = dev_fwnode(dev);
> > + int ret;
> > +
> > + /*
> > + * The AD7768-1 allows two primary methods for driving the SYNC_IN pin
> > + * to synchronize one or more devices:
> > + * 1. Using an external GPIO.
> > + * 2. Using a SPI command, where the SYNC_OUT pin generates a
> > + * synchronization pulse that drives the SYNC_IN pin.
> > + */
> > + if (!fwnode_property_present(fwnode, "trigger-sources")) {
>
> I'm wondering if you can split the below to a separate function and do something like
>
> if (fwnode_property_present(...))
> return setup_trigger_source(...);
>
> ...
> en_spi_sync = true;
> return 0;
>
> > + /*
> > + * In the absence of trigger-sources property, enable self
> > + * synchronization over SPI (SYNC_OUT).
> > + */
> > + st->en_spi_sync = true;
> > + return 0;
> > + }
> > +
> > + ret = fwnode_property_get_reference_args(fwnode,
> > + "trigger-sources",
> > + "#trigger-source-cells",
> > + 0,
> > + AD7768_TRIGGER_SOURCE_SYNC_IDX,
> > + &args);
>
>
> __free(fwnode_handle) ?
For args.fwnode?
That's fiddly to do and needs a different local variable to...
>
> > + if (ret)
> > + return ret;
> > +
> > + fwnode = args.fwnode;
this one.
You could wrap it up in a function to make that works cleanly.
So something similar to fwnode_find_reference() but with the
rest of the arguments. Is there appetite for such a wrapper
in the generic property code?
> > + /* First, try getting the GPIO trigger source */
> > + if (fwnode_device_is_compatible(fwnode, "gpio-trigger")) {
> > + st->gpio_sync_in = devm_fwnode_gpiod_get_index(dev, fwnode,
> > + NULL,
> > + 0,
> > + GPIOD_OUT_LOW,
> > + "sync-in");
> > + ret = PTR_ERR_OR_ZERO(st->gpio_sync_in);
> > + goto out_put_node;
> > + }
> > +
> > + /*
> > + * TODO: Support the other cases when we have a trigger subsystem to
> > + * reliably handle other types of devices as trigger sources.
> > + *
> > + * For now, return an error message. For self triggering, omit the
> > + * trigger-sources property.
> > + */
> > + ret = dev_err_probe(dev, -EOPNOTSUPP, "Invalid synchronization trigger source\n");
> > +
> > +out_put_node:
>
> The above will allow to get rid of this label.
>
> > + fwnode_handle_put(args.fwnode);
> > + return ret;
> > +}
>
Powered by blists - more mailing lists