[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <2025052155-macaw-deplored-8eb9@gregkh>
Date: Wed, 21 May 2025 06:21:10 +0200
From: Greg KH <gregkh@...uxfoundation.org>
To: Donny-Dev <donnyturizo13@...il.com>
Cc: linux-staging@...ts.linux.dev, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] staging: rtl8723bs: rename _Read_EEPROM to _read_eeprom
On Tue, May 20, 2025 at 10:26:10PM +0000, Donny-Dev wrote:
> This patch fixes a checkpatch
> warning by renaming the function
> _Read_EEPROM to follow the
> kernel coding style (snake_case).
>
> Signed-off-by: Donny-Dev <donnyturizo13@...il.com>
> ---
> drivers/staging/rtl8723bs/core/rtw_cmd.c | 2 +-
> drivers/staging/rtl8723bs/include/rtw_cmd.h | 2 +-
> drivers/staging/rtl8723bs/include/rtw_mlme_ext.h | 2 +-
> 3 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/staging/rtl8723bs/core/rtw_cmd.c b/drivers/staging/rtl8723bs/core/rtw_cmd.c
> index 1c9e8b01d..557bfdf09 100644
> --- a/drivers/staging/rtl8723bs/core/rtw_cmd.c
> +++ b/drivers/staging/rtl8723bs/core/rtw_cmd.c
> @@ -15,7 +15,7 @@ static struct _cmd_callback rtw_cmd_callback[] = {
> {GEN_CMD_CODE(_Write_BBREG), NULL},
> {GEN_CMD_CODE(_Read_RFREG), &rtw_getbbrfreg_cmdrsp_callback},
> {GEN_CMD_CODE(_Write_RFREG), NULL}, /*5*/
> - {GEN_CMD_CODE(_Read_EEPROM), NULL},
> + {GEN_CMD_CODE(_read_eeprom), NULL},
> {GEN_CMD_CODE(_Write_EEPROM), NULL},
> {GEN_CMD_CODE(_Read_EFUSE), NULL},
> {GEN_CMD_CODE(_Write_EFUSE), NULL},
> diff --git a/drivers/staging/rtl8723bs/include/rtw_cmd.h b/drivers/staging/rtl8723bs/include/rtw_cmd.h
> index cb44119ce..e4e7e350d 100644
> --- a/drivers/staging/rtl8723bs/include/rtw_cmd.h
> +++ b/drivers/staging/rtl8723bs/include/rtw_cmd.h
> @@ -636,7 +636,7 @@ enum {
> GEN_CMD_CODE(_Write_BBREG),
> GEN_CMD_CODE(_Read_RFREG),
> GEN_CMD_CODE(_Write_RFREG), /*5*/
> - GEN_CMD_CODE(_Read_EEPROM),
> + GEN_CMD_CODE(_read_eeprom),
> GEN_CMD_CODE(_Write_EEPROM),
> GEN_CMD_CODE(_Read_EFUSE),
> GEN_CMD_CODE(_Write_EFUSE),
> diff --git a/drivers/staging/rtl8723bs/include/rtw_mlme_ext.h b/drivers/staging/rtl8723bs/include/rtw_mlme_ext.h
> index 208040874..63373d665 100644
> --- a/drivers/staging/rtl8723bs/include/rtw_mlme_ext.h
> +++ b/drivers/staging/rtl8723bs/include/rtw_mlme_ext.h
> @@ -684,7 +684,7 @@ enum {
> GEN_EVT_CODE(_Read_MACREG) = 0, /*0*/
> GEN_EVT_CODE(_Read_BBREG),
> GEN_EVT_CODE(_Read_RFREG),
> - GEN_EVT_CODE(_Read_EEPROM),
> + GEN_EVT_CODE(_read_eeprom),
> GEN_EVT_CODE(_Read_EFUSE),
> GEN_EVT_CODE(_Read_CAM), /*5*/
> GEN_EVT_CODE(_Get_BasicRate),
> --
> 2.43.0
>
>
Hi,
This is the friendly patch-bot of Greg Kroah-Hartman. You have sent him
a patch that has triggered this response. He used to manually respond
to these common problems, but in order to save his sanity (he kept
writing the same thing over and over, yet to different people), I was
created. Hopefully you will not take offence and will fix the problem
in your patch and resubmit it so that it can be accepted into the Linux
kernel tree.
You are receiving this message because of the following common error(s)
as indicated below:
- It looks like you did not use your "real" name for the patch on either
the Signed-off-by: line, or the From: line (both of which have to
match). Please read the kernel file,
Documentation/process/submitting-patches.rst for how to do this
correctly.
If you wish to discuss this problem further, or you have questions about
how to resolve this issue, please feel free to respond to this email and
Greg will reply once he has dug out from the pending patches received
from other developers.
thanks,
greg k-h's patch email bot
Powered by blists - more mailing lists