lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <953ac19b2ff434a3abb3787720fefeef5ceda129.camel@intel.com>
Date: Thu, 28 Aug 2025 02:01:13 +0000
From: "Edgecombe, Rick P" <rick.p.edgecombe@...el.com>
To: "pbonzini@...hat.com" <pbonzini@...hat.com>, "seanjc@...gle.com"
	<seanjc@...gle.com>
CC: "kvm@...r.kernel.org" <kvm@...r.kernel.org>, "Annapurve, Vishal"
	<vannapurve@...gle.com>, "linux-kernel@...r.kernel.org"
	<linux-kernel@...r.kernel.org>, "Zhao, Yan Y" <yan.y.zhao@...el.com>,
	"michael.roth@....com" <michael.roth@....com>, "Weiny, Ira"
	<ira.weiny@...el.com>
Subject: Re: [RFC PATCH 04/12] KVM: x86/mmu: Rename kvm_tdp_map_page() to
 kvm_tdp_prefault_page()

On Tue, 2025-08-26 at 17:05 -0700, Sean Christopherson wrote:
> Rename kvm_tdp_map_page() to kvm_tdp_prefault_page() now that it's used
> only by kvm_arch_vcpu_pre_fault_memory().
> 
> No functional change intended.

I realize you are just trying to do map->prefault here, but "page" seems
redundant once you have "prefault" in the name. Why page here vs all the other
fault handler functions without it?

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ