[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <aLClCzTepEk7bczL@google.com>
Date: Thu, 28 Aug 2025 11:50:51 -0700
From: Sean Christopherson <seanjc@...gle.com>
To: Rick P Edgecombe <rick.p.edgecombe@...el.com>
Cc: "pbonzini@...hat.com" <pbonzini@...hat.com>, "kvm@...r.kernel.org" <kvm@...r.kernel.org>,
Vishal Annapurve <vannapurve@...gle.com>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>, Yan Y Zhao <yan.y.zhao@...el.com>,
"michael.roth@....com" <michael.roth@....com>, Ira Weiny <ira.weiny@...el.com>
Subject: Re: [RFC PATCH 04/12] KVM: x86/mmu: Rename kvm_tdp_map_page() to kvm_tdp_prefault_page()
On Thu, Aug 28, 2025, Rick P Edgecombe wrote:
> On Tue, 2025-08-26 at 17:05 -0700, Sean Christopherson wrote:
> > Rename kvm_tdp_map_page() to kvm_tdp_prefault_page() now that it's used
> > only by kvm_arch_vcpu_pre_fault_memory().
> >
> > No functional change intended.
>
> I realize you are just trying to do map->prefault here, but "page" seems
> redundant once you have "prefault" in the name. Why page here vs all the other
> fault handler functions without it?
kvm_tdp_prefault() feels a bit ambiguous/bare. Many of the fault helpers do have
"page", it's just before the fault part.
kvm_mmu_finish_page_fault
kvm_handle_page_fault
kvm_tdp_page_fault
direct_page_fault
nonpaging_page_fault
kvm_tdp_mmu_page_fault
(and probably more)
How about kvm_tdp_page_prefault()? Or kvm_tdp_do_prefault(), but I think I like
kvm_tdp_page_prefault() a little more.
Powered by blists - more mailing lists