[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <CAMj1kXEwK0znXcR=rp=r0cw+JjBM1i7=mK=u6-=RSB=4dsnHzw@mail.gmail.com>
Date: Fri, 29 Aug 2025 18:37:05 +0200
From: Ard Biesheuvel <ardb@...nel.org>
To: Eric Biggers <ebiggers@...nel.org>
Cc: linux-crypto@...r.kernel.org, linux-kernel@...r.kernel.org,
"Jason A . Donenfeld" <Jason@...c4.com>, x86@...nel.org, linux-arm-kernel@...ts.infradead.org
Subject: Re: [PATCH 00/12] ChaCha and BLAKE2s cleanups
On Wed, 27 Aug 2025 at 17:14, Eric Biggers <ebiggers@...nel.org> wrote:
>
> This series is targeting libcrypto-next. It can also be retrieved from:
>
> git fetch https://git.kernel.org/pub/scm/linux/kernel/git/ebiggers/linux.git chacha-blake2s-v1
>
> This series consolidates how the ChaCha and BLAKE2s code is organized.
> This is essentially the same change that I made to the other algorithms,
> so this should be fairly boring by now.
>
> These algorithms were the last two users of
> lib/crypto/$(SRCARCH)/{Makefile,Kconfig}. So this series removes all
> those files, finishing the transition to the centralized build process
> (at least for the algorithms supported by lib/crypto/ so far).
>
> This series also makes the arch-optimized BLAKE2s code start being
> enabled by default, again following the pattern of the other algorithms.
>
> Finally, it adds a KUnit test suite for BLAKE2s and deletes the older
> blake2s-selftest.
>
> Eric Biggers (12):
> arm: configs: Remove obsolete assignments to CRYPTO_CHACHA20_NEON
> crypto: chacha - register only "-lib" drivers
> lib/crypto: chacha: Remove unused function chacha_is_arch_optimized()
> lib/crypto: chacha: Rename chacha.c to chacha-block-generic.c
> lib/crypto: chacha: Rename libchacha.c to chacha.c
> lib/crypto: chacha: Consolidate into single module
> lib/crypto: x86/blake2s: Reduce size of BLAKE2S_SIGMA2
> lib/crypto: blake2s: Remove obsolete self-test
> lib/crypto: blake2s: Always enable arch-optimized BLAKE2s code
> lib/crypto: blake2s: Move generic code into blake2s.c
> lib/crypto: blake2s: Consolidate into single C translation unit
> lib/crypto: tests: Add KUnit tests for BLAKE2s
>
Reviewed-by: Ard Biesheuvel <ardb@...nel.org>
Powered by blists - more mailing lists