[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <34edaa0d-0d5f-4041-9a3d-fb5b2dd584e8@lucifer.local>
Date: Fri, 29 Aug 2025 13:31:41 +0100
From: Lorenzo Stoakes <lorenzo.stoakes@...cle.com>
To: David Hildenbrand <david@...hat.com>
Cc: linux-kernel@...r.kernel.org, Zi Yan <ziy@...dia.com>,
SeongJae Park <sj@...nel.org>, Alexander Potapenko <glider@...gle.com>,
Andrew Morton <akpm@...ux-foundation.org>,
Brendan Jackman <jackmanb@...gle.com>,
Christoph Lameter <cl@...two.org>, Dennis Zhou <dennis@...nel.org>,
Dmitry Vyukov <dvyukov@...gle.com>, dri-devel@...ts.freedesktop.org,
intel-gfx@...ts.freedesktop.org, iommu@...ts.linux.dev,
io-uring@...r.kernel.org, Jason Gunthorpe <jgg@...dia.com>,
Jens Axboe <axboe@...nel.dk>, Johannes Weiner <hannes@...xchg.org>,
John Hubbard <jhubbard@...dia.com>, kasan-dev@...glegroups.com,
kvm@...r.kernel.org, "Liam R. Howlett" <Liam.Howlett@...cle.com>,
Linus Torvalds <torvalds@...ux-foundation.org>,
linux-arm-kernel@...s.com, linux-arm-kernel@...ts.infradead.org,
linux-crypto@...r.kernel.org, linux-ide@...r.kernel.org,
linux-kselftest@...r.kernel.org, linux-mips@...r.kernel.org,
linux-mmc@...r.kernel.org, linux-mm@...ck.org,
linux-riscv@...ts.infradead.org, linux-s390@...r.kernel.org,
linux-scsi@...r.kernel.org, Marco Elver <elver@...gle.com>,
Marek Szyprowski <m.szyprowski@...sung.com>,
Michal Hocko <mhocko@...e.com>, Mike Rapoport <rppt@...nel.org>,
Muchun Song <muchun.song@...ux.dev>, netdev@...r.kernel.org,
Oscar Salvador <osalvador@...e.de>, Peter Xu <peterx@...hat.com>,
Robin Murphy <robin.murphy@....com>,
Suren Baghdasaryan <surenb@...gle.com>, Tejun Heo <tj@...nel.org>,
virtualization@...ts.linux.dev, Vlastimil Babka <vbabka@...e.cz>,
wireguard@...ts.zx2c4.com, x86@...nel.org
Subject: Re: [PATCH v1 06/36] mm/page_alloc: reject unreasonable
folio/compound page sizes in alloc_contig_range_noprof()
On Fri, Aug 29, 2025 at 12:06:21PM +0200, David Hildenbrand wrote:
> On 28.08.25 16:37, Lorenzo Stoakes wrote:
> > On Thu, Aug 28, 2025 at 12:01:10AM +0200, David Hildenbrand wrote:
> > > Let's reject them early, which in turn makes folio_alloc_gigantic() reject
> > > them properly.
> > >
> > > To avoid converting from order to nr_pages, let's just add MAX_FOLIO_ORDER
> > > and calculate MAX_FOLIO_NR_PAGES based on that.
> > >
> > > Reviewed-by: Zi Yan <ziy@...dia.com>
> > > Acked-by: SeongJae Park <sj@...nel.org>
> > > Signed-off-by: David Hildenbrand <david@...hat.com>
> >
> > Some nits, but overall LGTM so:
> >
> > Reviewed-by: Lorenzo Stoakes <lorenzo.stoakes@...cle.com>
> >
> > > ---
> > > include/linux/mm.h | 6 ++++--
> > > mm/page_alloc.c | 5 ++++-
> > > 2 files changed, 8 insertions(+), 3 deletions(-)
> > >
> > > diff --git a/include/linux/mm.h b/include/linux/mm.h
> > > index 00c8a54127d37..77737cbf2216a 100644
> > > --- a/include/linux/mm.h
> > > +++ b/include/linux/mm.h
> > > @@ -2055,11 +2055,13 @@ static inline long folio_nr_pages(const struct folio *folio)
> > >
> > > /* Only hugetlbfs can allocate folios larger than MAX_ORDER */
> > > #ifdef CONFIG_ARCH_HAS_GIGANTIC_PAGE
> > > -#define MAX_FOLIO_NR_PAGES (1UL << PUD_ORDER)
> > > +#define MAX_FOLIO_ORDER PUD_ORDER
> > > #else
> > > -#define MAX_FOLIO_NR_PAGES MAX_ORDER_NR_PAGES
> > > +#define MAX_FOLIO_ORDER MAX_PAGE_ORDER
> > > #endif
> > >
> > > +#define MAX_FOLIO_NR_PAGES (1UL << MAX_FOLIO_ORDER)
> >
> > BIT()?
>
> I don't think we want to use BIT whenever we convert from order -> folio --
> which is why we also don't do that in other code.
It seems a bit arbitrary, like we open-code this (at risk of making a mistake)
in some places but not others.
>
> BIT() is nice in the context of flags and bitmaps, but not really in the
> context of converting orders to pages.
It's nice for setting a specific bit :)
>
> One could argue that maybe one would want a order_to_pages() helper (that
> could use BIT() internally), but I am certainly not someone that would
> suggest that at this point ... :)
I mean maybe.
Anyway as I said none of this is massively important, the open-coding here is
correct, just seems silly.
>
> >
> > > +
> > > /*
> > > * compound_nr() returns the number of pages in this potentially compound
> > > * page. compound_nr() can be called on a tail page, and is defined to
> > > diff --git a/mm/page_alloc.c b/mm/page_alloc.c
> > > index baead29b3e67b..426bc404b80cc 100644
> > > --- a/mm/page_alloc.c
> > > +++ b/mm/page_alloc.c
> > > @@ -6833,6 +6833,7 @@ static int __alloc_contig_verify_gfp_mask(gfp_t gfp_mask, gfp_t *gfp_cc_mask)
> > > int alloc_contig_range_noprof(unsigned long start, unsigned long end,
> > > acr_flags_t alloc_flags, gfp_t gfp_mask)
Funny btw th
> > > {
> > > + const unsigned int order = ilog2(end - start);
> > > unsigned long outer_start, outer_end;
> > > int ret = 0;
> > >
> > > @@ -6850,6 +6851,9 @@ int alloc_contig_range_noprof(unsigned long start, unsigned long end,
> > > PB_ISOLATE_MODE_CMA_ALLOC :
> > > PB_ISOLATE_MODE_OTHER;
> > >
> > > + if (WARN_ON_ONCE((gfp_mask & __GFP_COMP) && order > MAX_FOLIO_ORDER))
> > > + return -EINVAL;
> >
> > Possibly not worth it for a one off, but be nice to have this as a helper function, like:
> >
> > static bool is_valid_order(gfp_t gfp_mask, unsigned int order)
> > {
> > return !(gfp_mask & __GFP_COMP) || order <= MAX_FOLIO_ORDER;
> > }
> >
> > Then makes this:
> >
> > if (WARN_ON_ONCE(!is_valid_order(gfp_mask, order)))
> > return -EINVAL;
> >
> > Kinda self-documenting!
>
> I don't like it -- especially forwarding __GFP_COMP.
>
> is_valid_folio_order() to wrap the order check? Also not sure.
OK, it's not a big deal.
Can we have a comment explaining this though? As people might be confused
as to why we check this here and not elsewhere.
>
> So I'll leave it as is I think.
Right fine.
>
> Thanks for all the review!
>
> --
> Cheers
>
> David / dhildenb
>
Powered by blists - more mailing lists