[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20070108132548.GA2324@ff.dom.local>
Date: Mon, 8 Jan 2007 14:25:48 +0100
From: Jarek Poplawski <jarkao2@...pl>
To: Paul Moore <paul.moore@...com>
Cc: netdev@...r.kernel.org
Subject: Re: [PATCH] INET: fix incorrect "inet_sock->is_icsk" assignment
On 04-01-2007 21:04, Paul Moore wrote:
...
> +++ net-2.6.20_bugfix_2/net/ipv4/af_inet.c
> @@ -305,7 +305,7 @@ lookup_protocol:
> sk->sk_reuse = 1;
>
> inet = inet_sk(sk);
> - inet->is_icsk = INET_PROTOSW_ICSK & answer_flags;
> + inet->is_icsk = (INET_PROTOSW_ICSK & answer_flags) == INET_PROTOSW_ICSK;
Isn't this more readable like this?:
inet->is_icsk = (INET_PROTOSW_ICSK & answer_flags) != 0;
Regards,
Jarek P.
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists