lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 18 Jul 2007 08:58:41 +0530
From:	Abhijit Menon-Sen <>
Subject: tc filter add ... fw ... action drop


Is it a bug that:

  # tc filter add dev eth0 parent 1: protocol ip prio 0 handle 0xfffffff
    fw police rate 1 burst 1 mpu 0 mtu 1 action drop
creates a filter that looks like:

  # tc filter ls dev eth0
  filter parent 1: protocol ip pref 49152 fw 
  filter parent 1: protocol ip pref 49152 fw handle 0xfffffff police 0x1
  rate 0bit burst 0b mtu 1b action reclassify
  ref -543190236 bind 4

(which reclassifies and thus lets 0xfffffff-marked packets through).

I'm pretty sure this used to work under 2.4.x (though I no longer have a
2.4 box to test with), but it hasn't worked on any of the 2.6.x kernels
I've tried (with both iproute2-ss060323 and 070710).

I haven't been able to find anything that suggests this change is
intentional. If it's not immediately obvious to anyone what the
problem is, I could try to track it down.

-- ams
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to
More majordomo info at

Powered by blists - more mailing lists