[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <46A09B51.6030301@trash.net>
Date: Fri, 20 Jul 2007 13:24:01 +0200
From: Patrick McHardy <kaber@...sh.net>
To: Krishna Kumar2 <krkumar2@...ibm.com>
CC: davem@...emloft.net, gaagaan@...il.com,
general@...ts.openfabrics.org, hadi@...erus.ca,
herbert@...dor.apana.org.au, jagana@...ibm.com, jeff@...zik.org,
johnpol@....mipt.ru, kumarkr@...ux.ibm.com, mcarlson@...adcom.com,
mchan@...adcom.com, netdev@...r.kernel.org,
peter.p.waskiewicz.jr@...el.com, rdreier@...co.com,
rick.jones2@...com, Robert.Olsson@...a.slu.se, sri@...ibm.com,
tgraf@...g.ch, xma@...ibm.com
Subject: Re: [PATCH 05/10] sch_generic.c changes.
Krishna Kumar2 wrote:
> Patrick McHardy <kaber@...sh.net> wrote on 07/20/2007 03:41:01 PM:
>
>>> -static inline int qdisc_restart(struct net_device *dev)
>>> +static inline int qdisc_restart(struct net_device *dev,
>>> + struct sk_buff_head *blist)
>>> {
>>> struct Qdisc *q = dev->qdisc;
>>> struct sk_buff *skb;
>>> - unsigned lockless;
>>> + unsigned getlock; /* whether we need to get lock or not */
>>>
>> Unrelated rename, please get rid of this to reduce the noise.
>>
>
> OK, I guess I should have sent that change earlier :) The reason to change
> the name is to avoid (double-negative) checks like :
>
> if (!lockless)
> to
> if (getlock).
>
> I will remove these changes.
>
I guess you could put it in another patch. But frankly, I think
the biggest uglyness is the conditional locking, not naming or
double negation, so it won't really make the code any nicer :)
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists