[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4702B1FD.70102@hartkopp.net>
Date: Tue, 02 Oct 2007 23:02:53 +0200
From: Oliver Hartkopp <oliver@...tkopp.net>
To: Arnaldo Carvalho de Melo <acme@...stprotocols.net>
CC: Urs Thuermann <urs@...ogud.escape.de>, netdev@...r.kernel.org,
David Miller <davem@...emloft.net>,
Patrick McHardy <kaber@...sh.net>,
Thomas Gleixner <tglx@...utronix.de>,
YOSHIFUJI Hideaki <yoshfuji@...ux-ipv6.org>,
"Eric W. Biederman" <ebiederm@...ssion.com>,
Oliver Hartkopp <oliver@...tkopp.net>,
Oliver Hartkopp <oliver.hartkopp@...kswagen.de>,
Urs Thuermann <urs.thuermann@...kswagen.de>
Subject: Re: [PATCH 5/7] CAN: Add virtual CAN netdevice driver
Arnaldo Carvalho de Melo wrote:
> Em Tue, Oct 02, 2007 at 03:10:11PM +0200, Urs Thuermann escreveu:
>
>> +
>> +#ifdef CONFIG_CAN_DEBUG_DEVICES
>> +static int debug;
>> +module_param(debug, int, S_IRUGO);
>> +#endif
>>
>
> Can debug be a boolean? Like its counterpart on DCCP:
>
> net/dccp/proto.c:
>
> module_param(dccp_debug, bool, 0444);
>
'debug' should remain an integer to be able to specifiy debug-levels or
bit-fields for different Debug outputs.
> Where we also use a namespace prefix, for those of us who use ctags or
> cscope.
>
Even if i don't have any general objections to rename this 'debug' to
'vcan_debug', it looks like an 'overnamed' module parameter for me. Is
this a genereal naming scheme recommendation for debug module_params?
>
>> +/*
>> + * CAN test feature:
>> + * Enable the echo on driver level for testing the CAN core echo modes.
>> + * See Documentation/networking/can.txt for details.
>> + */
>> +
>> +static int echo; /* echo testing. Default: 0 (Off) */
>> +module_param(echo, int, S_IRUGO);
>> +MODULE_PARM_DESC(echo, "Echo sent frames (for testing). Default: 0 (Off)");
>>
>
> echo also seems to be a boolean
>
>
Yes. This is definitely a boolean candidate. We'll change that.
Thanks,
Oliver
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists