[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20071029.013931.203090879.davem@davemloft.net>
Date: Mon, 29 Oct 2007 01:39:31 -0700 (PDT)
From: David Miller <davem@...emloft.net>
To: eliezert@...adcom.com
Cc: mchan@...adcom.com, jeff@...zik.org, netdev@...r.kernel.org,
masbock@...ibm.com
Subject: Re: [RFC][BNX2X] .h files rewrite
From: "Eliezer Tamir" <eliezert@...adcom.com>
Date: Sun, 28 Oct 2007 22:21:14 +0200
Overall things look significantly better, thanks a lot!
However, there is still one set of magic constants in here
which I hope you can clear up:
> +static const struct raw_op init_ops[] = {
> +#define PRS_COMMON_START 0
> + {OP_WR, PRS_REG_INC_VALUE, 0xf},
> + {OP_WR, PRS_REG_EVENT_ID_1, 0x45},
> + {OP_WR, PRS_REG_EVENT_ID_2, 0x84},
> + {OP_WR, PRS_REG_EVENT_ID_3, 0x6},
> + {OP_WR, PRS_REG_NO_MATCH_EVENT_ID, 0x4},
> + {OP_WR, PRS_REG_CM_HDR_TYPE_0, 0x0},
> + {OP_WR, PRS_REG_CM_HDR_TYPE_1, 0x12170000},
> + {OP_WR, PRS_REG_CM_HDR_TYPE_2, 0x22170000},
> + {OP_WR, PRS_REG_CM_HDR_TYPE_3, 0x32170000},
> + {OP_ZR, PRS_REG_CM_HDR_TYPE_4, 0x5},
> + {OP_WR, PRS_REG_CM_HDR_LOOPBACK_TYPE_1, 0x12150000},
> + {OP_WR, PRS_REG_CM_HDR_LOOPBACK_TYPE_2, 0x22150000},
> + {OP_WR, PRS_REG_CM_HDR_LOOPBACK_TYPE_3, 0x32150000},
> + {OP_ZR, PRS_REG_CM_HDR_LOOPBACK_TYPE_4, 0x4},
etc. etc.
Take care.
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists