[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <473A6B11.7090208@redhat.com>
Date: Tue, 13 Nov 2007 22:27:13 -0500
From: Hideo AOKI <haoki@...hat.com>
To: Herbert Xu <herbert@...dor.apana.org.au>
CC: David Miller <davem@...emloft.net>,
netdev <netdev@...r.kernel.org>,
Satoshi Oshima <satoshi.oshima.fk@...achi.com>,
Andi Kleen <andi@...stfloor.org>,
Stephen Hemminger <shemminger@...ux-foundation.org>,
Evgeniy Polyakov <johnpol@....mipt.ru>,
yoshfuji@...ux-ipv6.org,
Yumiko Sugita <yumiko.sugita.yf@...achi.com>
Subject: Re: [PATCH 2/5] accounting unit and variable
Hello,
Herbert Xu wrote:
> On Mon, Oct 29, 2007 at 05:23:10PM -0400, Hideo AOKI wrote:
>>
>> +#define SK_DATAGRAM_MEM_QUANTUM ((int)PAGE_SIZE)
>> +
>> +static inline int sk_datagram_pages(int amt)
>> +{
>> + return DIV_ROUND_UP(amt, SK_DATAGRAM_MEM_QUANTUM);
>> +}
>
> Does this really have to be int? Unsigned would let the compiler
> optimise this to a simple shift.
Thank you for the comment.
This inline function is used to calculate the first argument of atomic_add()
and atomic_sub(). Since the argument is int, I believe that using int is
better than using unsigned int.
Best regards,
Hideo
--
Hitachi Computer Products (America) Inc.
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists