[<prev] [next>] [day] [month] [year] [list]
Message-Id: <20071128.204739.130849440.takano@axe-inc.co.jp>
Date: Wed, 28 Nov 2007 20:47:39 +0900 (JST)
From: Ryousei Takano <takano-ryousei@...t.go.jp>
To: netdev@...r.kernel.org
Cc: shemminger@...ux-foundation.org, kaber@...sh.net,
dada1@...mosbay.com, t.kudoh@...t.go.jp
Subject: [PATCHv3 net-2.6.25 0/3] PSPacer qdisc module
Hi all,
This is the 3rd version of PSPacer patches.
PSPacer (Precise Software Pacer) is a qdisc module which realizes
precise transmission bandwidth control. It makes bursty traffic which is
often generated by TCP smooth without any special hardware.
For your information, please see my previous post:
http://marc.info/?l=linux-netdev&m=119570861526290&w=2
Changes (v3):
* fixed alloc_gap_packet().
* fixed recalc_gapsize().
* changed the type of 'clock' from gapclock_t to u64.
* changed rate/allocated_rate/gapsize variables from u32 to u64.
* changed from tc_psp_xstats to gnet_stats_basic.
* added checking whether it is a root qdisc in psp_init().
* fixed qdisc_tree_decrease_qlen stuff.
* removed psp_change_qdisc().
* fixed coding style.
Changes (v2):
* checked by the checkpatch.pl script.
* introduced struct gaphdr.
* removed the HTB-way of using a "direct class".
* removed unnecessary skb_reserve() and magic values in alloc_gap_packet().
* added a proper check when skb_clone() fails in psp_dequeue().
* used qdisc_tree_decrease_qlen() in psp_graft().
Usage:
# tc qdisc add dev eth0 root handle 1: psp default 1
# tc class add dev eth0 parent 1: classid 1:1 psp rate 500mbit
# tc qdisc add dev eth0 parent 1:1 handle 10: pfifo
Patches:
[1/3] PSPacer kernel part
[2/3] PSPacer tc part
[3/3] PSPacer tc man page
Best regards,
Ryousei Takano
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists