[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <1198246651.6183.121.camel@localhost>
Date: Fri, 21 Dec 2007 06:17:31 -0800
From: Joe Perches <joe@...ches.com>
To: YOSHIFUJI Hideaki /
吉藤英明
<yoshfuji@...ux-ipv6.org>
Cc: davem@...emloft.net, netdev@...r.kernel.org
Subject: Re: [TCP]: Convert several length variable to unsigned.
On Fri, 2007-12-21 at 16:48 +0900, YOSHIFUJI Hideaki / 吉藤英明 wrote:
> diff --git a/net/ipv6/tcp_ipv6.c b/net/ipv6/tcp_ipv6.c
> index 93980c3..3b4169c 100644
> --- a/net/ipv6/tcp_ipv6.c
> +++ b/net/ipv6/tcp_ipv6.c
> @@ -985,7 +985,7 @@ static void tcp_v6_send_reset(struct sock *sk, struct sk_buff *skb)
> struct tcphdr *th = tcp_hdr(skb), *t1;
> struct sk_buff *buff;
> struct flowi fl;
> - int tot_len = sizeof(*th);
> + unsigned int tot_len = sizeof(*th);
> #ifdef CONFIG_TCP_MD5SIG
> struct tcp_md5sig_key *key;
> #endif
> @@ -1085,7 +1085,7 @@ static void tcp_v6_send_ack(struct tcp_timewait_sock *tw,
> struct tcphdr *th = tcp_hdr(skb), *t1;
> struct sk_buff *buff;
> struct flowi fl;
> - int tot_len = sizeof(struct tcphdr);
> + unsigned int tot_len = sizeof(struct tcphdr);
> __be32 *topt;
> #ifdef CONFIG_TCP_MD5SIG
> struct tcp_md5sig_key *key;
Unrelated, but perhaps tot_len should be initialized in
a consistent fashion?
I think unsigned int tot_len = sizeof(struct tcphdr); is more readable.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists