lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Fri, 07 Mar 2008 08:58:54 +0100
From:	Jonas Bonn <>
To:	Andrew Morton <>
CC:,,, Greg KH <>

Andrew Morton wrote:
> Bah.
> a) DECLARE_PCI_DEVICE_TABLE is misnamed.  It is used to *define* tables,
>    not to declare them.  It should be called DEFINE_PCI_DEVICE_TABLE.

Fair enough...

> b) It's lame, anyway.  We could implement any number of such helper
>    thingies, but we choose not to.

When I originally proposed these cleanups, I posted opened-coded 
versions.  That was deemed to be ugly and using a macro was suggested. 
So now I've reworked this with a macro, and now the macro is being 
deemed to be ugly, too!

The point of this exercise wasn't really to do a macro at all; the point 
was to get these structures marked 'const'  and into __devinitconst 
where they belong.  Whether the open-coded approach or the macro is the 
way to go, is all the same to me; any guidance on how to proceed would 
be appreciated.

To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to
More majordomo info at

Powered by blists - more mailing lists