[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20080507175518.GY2217@solarflare.com>
Date: Wed, 7 May 2008 18:55:19 +0100
From: Ben Hutchings <bhutchings@...arflare.com>
To: Andrew Morton <akpm@...ux-foundation.org>
Cc: netdev@...r.kernel.org, linux-net-drivers@...arflare.com
Subject: Re: New driver "sfc" for Solarstorm SFC4000 controller.
Ben Hutchings wrote:
> Andrew Morton wrote:
> > On Fri, 2 May 2008 17:05:35 +0100 Ben Hutchings <bhutchings@...arflare.com> wrote:
<snip>
> > > > > + rx_buf->page = alloc_pages(__GFP_COLD | __GFP_COMP | GFP_ATOMIC,
> > > > > + efx->rx_buffer_order);
> > > >
> > > > I don't think we should be using the open-coded __GFP_COMP here. That's
> > > > more an mm-internal thing.
> > >
> > > What's the alternative?
> >
> > Just remove the __GFP_COMP, I expect. __GFP_COMP will ask the page
> > allocator to add extra book-keeping info to the pageframe (via
> > prep_compound_page()). I doubt if the driver uses that information.
>
> It looks like this flag was used by mistake, based on past experience with
> a driver that needed buffers to be mapped into user space. The original
> author of the RX page-allocation code is away at the moment, so I will
> have to wait to ask why he used it.
This is not a mistake. We need multi-page buffers to be treated as
compound pages because once they are attached to an skbuff they will
be freed by skb_release_data() calling put_page(), not __free_pages().
Ben.
--
Ben Hutchings, Senior Software Engineer, Solarflare Communications
Not speaking for my employer; that's the marketing department's job.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists