lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sun, 15 Jun 2008 15:56:12 +0930
From:	David Newall <>
To:	Németh Márton <>
CC:	Jeff Garzik <>,,
	Trivial Patch Monkey <>,
	LKML <>
Subject: Re: [PATCH 2/2] 8139too: different style cleanups

Németh Márton wrote:
>  #  define DPRINTK(fmt, args...) \
> -	printk(KERN_DEBUG "%s: " fmt, __FUNCTION__ , ## args)
> +	printk(KERN_DEBUG "%s: " fmt, __func__ , ## args)

Why change __FUNCTION__ to __func__?  I don't even know where __func__
come from?  Assuming that it isn't totally broken, and I'll believe that
it isn't, then would it be compiler-specific?   __FUNCTION__ is standard
and that's more than enough reason to prefer that form to any
non-standard variation.

Yes to the following; no to all the rest:


To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to
More majordomo info at

Powered by blists - more mailing lists