[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20080619.190854.188264452.davem@davemloft.net>
Date: Thu, 19 Jun 2008 19:08:54 -0700 (PDT)
From: David Miller <davem@...emloft.net>
To: wangchen@...fujitsu.com
Cc: shemminger@...tta.com, netdev@...r.kernel.org, kaber@...sh.net
Subject: Re: [PATCH net-next 3/8] bridge: Check return of
dev_set_promiscuity
From: Wang Chen <wangchen@...fujitsu.com>
Date: Fri, 20 Jun 2008 08:55:00 +0800
Sigh...
> @@ -389,7 +389,10 @@ int br_add_if(struct net_bridge *br, struct net_device *dev)
> goto err2;
>
> rcu_assign_pointer(dev->br_port, p);
> - dev_set_promiscuity(dev, 1);
> + /* If promiscuity overflow, return error */
> + err = dev_set_promiscuity(dev, 1);
> + if (err)
> + goto err3;
Fixup this comment as I directed in my feedback for the previous patches.
These just look like turds all over the tree that you are adding for every
single dev_set_promiscuity() call site and it adds nothing to readability
or understandability of the code.
Anyways, Stephen also wanted you to implement this a different way.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists