[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20081002215502.q9and4a6kg4cs0o8@intran0x.frec.bull.fr>
Date: Thu, 02 Oct 2008 21:55:02 +0200
From: "Benjamin Thery " <Benjamin.Thery@...l.net>
To: Jarek Poplawski <jarkao2@...il.com>
Cc: Daniel Lezcano <dlezcano@...ibm.com>,
"David S. Miller" <davem@...emloft.net>,
netdev <netdev@...r.kernel.org>
Subject: Re: [PATCH] net: deadlock during net device unregistration - V2
Quoting Jarek Poplawski <jarkao2@...il.com>:
> On Thu, Oct 02, 2008 at 05:23:30PM +0200, Benjamin Thery wrote:
>> Jarek Poplawski wrote:
>>> On Wed, Oct 01, 2008 at 11:06:22PM +0200, Daniel Lezcano wrote:
>>>> Jarek Poplawski wrote:
>>>>> On Wed, Oct 01, 2008 at 04:14:35PM +0200, Benjamin Thery wrote:
>>> ...
>>>>>> --- net-next-2.6.orig/net/core/dst.c
>>>>>> +++ net-next-2.6/net/core/dst.c
>>>>>> @@ -328,6 +328,10 @@ static int dst_dev_event(struct notifier
>>>>>> dst_ifdown(dst, dev, event != NETDEV_DOWN);
>>>>>> }
>>>>>> mutex_unlock(&dst_gc_mutex);
>>>>>> +
>>>>>> + if (event == NETDEV_UNREGISTER &&
>>>>>> + cancel_delayed_work(&dst_gc_work))
>>>>>> + dst_gc_task(&dst_gc_work.work);
>>>>> Hmm... It seems this shouldn't work yet: cancel_delayed_work() can only
>>>>> kill this while on timer, but not when queued and maybe blocked already.
>>
>> You're right.
>>
>>>
>>> Hmm#2... Then maybe something like this?:
>>>
>>> if (event == NETDEV_UNREGISTER &&
>>> (cancel_delayed_work(&dst_gc_work) ||
>>> delayed_work_pending(&dst_gc_work)))
>>> dst_gc_task(&dst_gc_work.work);
>>
>> Hmmm... I'm not sure I understand what this change do?
>>
>> OK, I see this ensure we will run dst_gc_task() even if
>> cancel_delayed_work() failed and the work is still pending (ie. the
>> timer has expired and dst_gc_work is already in the queue).
>
> I think, this covers exactly the case of blocking you described, plus
> more... (the work is queued but not blocked).
>
>>
>> But what if the work was not pending at all at beginning?
>> We still need to run dst_gc_task().
>
> Maybe I miss something, but if this is really needed here then it
> looks like we are fixing more than "the blocking" bug BTW.
>
>>
>> Is something like this better?
>> (code expanded to be more readable)
>>
>> if (event == NETDEV_UNREGISTER) {
>> if (!delayed_work_pending(&dst_gc_work))
>> /* work is not scheduled (no timer, not in queue) */
>
> /* may be running too */
>
>> dst_gc_task(&dst_gc_work.work);
>> else if (cancel_delayed_work(&dst_gc_work) ||
>> delayed_work_pending(&dst_gc_work)))
>> /* work was scheduled (and may be blocked) */
>
> /* actually could be both running and pending here:
> * if it's after rearming
> */
>
>> dst_gc_task(&dst_gc_work.work);
>> else
>> /* dst_gc_task() is running, do nothing */
>
> So again !delayed_work_pending() - there could be the change of state
> while checking - but then looks a bit inconsistent. I think this should
> be OK too.
>
> As a matter of fact I've thought about something even simpler, which
> probably should help for all above concerns too:
>
> if (event == NETDEV_UNREGISTER)
> dst_gc_task(&dst_gc_work.work);
>
> dst_gc_task() locking allows for this, and running this two times in
> a row could be even faster than trying to cancel the unnecessary run.
I've thought a bit more about my last proposal and come to the same
conclusion as you, hmm, almost. I thought we could call
cancel_delayed_work() unconditionally and then dst_gc_task().
if (event == NETDEV_UNREGISTER) {
cancel_delayed_work(&dst_gc_work);
dst_gc_task(&dst_gc_work.work);
}
But, you're right, calling only dst_gc_task() seems fine to me.
I'll run some tests tomorrow and send a new patch.
Do we agree that this fix (calling dst_gc_task() in dst_dev_event())
is better/more appropriate than the first one (replacing rtnl_unlock()
by the non-blocking __rtnl_unlock() in linkwatch_event())?
Thanks,
Benjamin
>
> Jarek P.
>
>
----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists