[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87abbaw9rk.fsf@basil.nowhere.org>
Date: Fri, 05 Dec 2008 23:13:35 +0100
From: Andi Kleen <andi@...stfloor.org>
To: Ilpo Järvinen <ilpo.jarvinen@...sinki.fi>
Cc: David Miller <davem@...emloft.net>, netdev@...r.kernel.org
Subject: Re: [PATCH 01/10] tcp: force mss equality with the next skb too.
"Ilpo Järvinen" <ilpo.jarvinen@...sinki.fi> writes:
> +++ b/net/ipv4/tcp_input.c
> @@ -1575,11 +1575,10 @@ static struct sk_buff *tcp_shift_skb_data(struct sock *sk, struct sk_buff *skb,
> goto out;
> skb = tcp_write_queue_next(sk, prev);
>
> - if (!skb_can_shift(skb))
> - goto out;
> - if (skb == tcp_send_head(sk))
> - goto out;
> - if ((TCP_SKB_CB(skb)->sacked & TCPCB_TAGBITS) != TCPCB_SACKED_ACKED)
> + if (!skb_can_shift(skb) ||
> + (skb == tcp_send_head(sk)) ||
> + ((TCP_SKB_CB(skb)->sacked & TCPCB_TAGBITS) != TCPCB_SACKED_ACKED) ||
> + (mss != tcp_shift_mss(skb)))
> goto out;
Perhaps it's just me, but I think the code was far more readable
before your change.
-Andi
--
ak@...ux.intel.com
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists