[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20090403171024.GG19982@elte.hu>
Date: Fri, 3 Apr 2009 19:10:24 +0200
From: Ingo Molnar <mingo@...e.hu>
To: Eric Dumazet <dada1@...mosbay.com>
Cc: Tejun Heo <htejun@...il.com>,
Jeremy Fitzhardinge <jeremy@...p.org>,
linux kernel <linux-kernel@...r.kernel.org>,
Linux Netdev List <netdev@...r.kernel.org>,
Rusty Russell <rusty@...tcorp.com.au>
Subject: Re: [PATCH] percpu: convert SNMP mibs to new infra
* Eric Dumazet <dada1@...mosbay.com> wrote:
> Ingo Molnar a écrit :
> > * Tejun Heo <htejun@...il.com> wrote:
> >
> >> Hello, Eric, Ingo.
> >>
> >> Eric Dumazet wrote:
> >>> diff --git a/arch/x86/include/asm/percpu.h b/arch/x86/include/asm/percpu.h
> >>> index aee103b..6b82f6b 100644
> >>> --- a/arch/x86/include/asm/percpu.h
> >>> +++ b/arch/x86/include/asm/percpu.h
> >>> @@ -135,6 +135,9 @@ do { \
> >>> #define percpu_read(var) percpu_from_op("mov", per_cpu__##var)
> >>> #define percpu_write(var, val) percpu_to_op("mov", per_cpu__##var, val)
> >>> #define percpu_add(var, val) percpu_to_op("add", per_cpu__##var, val)
> >>> +#define indir_percpu_add(var, val) percpu_to_op("add", *(var), val)
> >>> +#define indir_percpu_inc(var) percpu_to_op("add", *(var), 1)
> >>> +#define indir_percpu_dec(var) percpu_to_op("add", *(var), -1)
> >>> #define percpu_sub(var, val) percpu_to_op("sub", per_cpu__##var, val)
> >>> #define percpu_and(var, val) percpu_to_op("and", per_cpu__##var, val)
> >>> #define percpu_or(var, val) percpu_to_op("or", per_cpu__##var, val)
> >> The final goal is to unify static and dynamic accesses but we
> >> aren't there yet, so, for the time being, we'll need some interim
> >> solutions. I would prefer percpu_ptr_add() tho.
> >
> > Yep, that's the standard naming scheme for new APIs: generic to
> > specific, left to right.
> >
>
> Here is a second version of the patch, with percpu_ptr_xxx convention,
> and more polished form (snmp_mib_free() was forgoten in previous RFC)
>
> Thank you all
>
> [PATCH] percpu: convert SNMP mibs to new infra
>
> Some arches can use percpu infrastructure for safe changes to mibs.
> (percpu_add() is safe against preemption and interrupts), but
> we want the real thing (a single instruction), not an emulation.
>
> On arches still using an emulation, its better to keep the two views
> per mib and preemption disable/enable
>
> This shrinks size of mibs by 50%, but also shrinks vmlinux text size
> (minimum IPV4 config)
>
> $ size vmlinux.old vmlinux.new
> text data bss dec hex filename
> 4308458 561092 1728512 6598062 64adae vmlinux.old
> 4303834 561092 1728512 6593438 649b9e vmlinux.new
Wow, that's pretty impressive!
> Signed-off-by: Eric Dumazet <dada1@...mosbay.com>
> ---
> arch/x86/include/asm/percpu.h | 3 +++
Acked-by: Ingo Molnar <mingo@...e.hu>
As far as x86 goes, feel free to pick it up into any of the
networking trees, these bits are easily merged and it's probably
best if the patch stays in a single piece - it looks compact enough
and if it breaks it's going to break in networking code.
Ingo
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists