[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4A13E5E5.4060007@cosmosbay.com>
Date: Wed, 20 May 2009 13:13:41 +0200
From: Eric Dumazet <dada1@...mosbay.com>
To: Jarek Poplawski <jarkao2@...il.com>
CC: David Miller <davem@...emloft.net>, nhorman@...driver.com,
lav@....ru, shemminger@...ux-foundation.org, netdev@...r.kernel.org
Subject: Re: [PATCH] net: fix rtable leak in net/ipv4/route.c
Jarek Poplawski a écrit :
> On Wed, May 20, 2009 at 08:14:28AM +0200, Eric Dumazet wrote:
>> + for (aux = rt_hash_table[i].chain;;) {
>> + if (aux == rth) {
>> + length += ONE;
>> + break;
>> + }
>> + if (compare_hash_inputs(&aux->fl, &rth->fl))
>> + break;
>> + aux = aux->u.dst.rt_next;
>> + }
>
> Very "interesting" for() usage, but isn't it more readable like this?:
>
> aux = rt_hash_table[i].chain;
> while (aux != rth) {
> if (compare_hash_inputs(&aux->fl, &rth->fl))
> break;
> aux = aux->u.dst.rt_next;
> }
well, this test is done two times, this is the difference...
>
> if (aux == rth)
> length += ONE;
>
> Jarek P.
I first wrote :
for (aux = rt_hash_table[i].chain ; ; aux = aux->u.dst.rt_next) {
if (aux == rth) {
length += ONE;
break;
}
if (compare_hash_inputs(&aux->fl, &rth->fl))
break;
}
but had to split the too long line, so ended in the form in the patch :)
Thank you
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists