[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <5D6A7C11-B300-4E39-BBDF-EF18C4BAE419@oracle.com>
Date: Thu, 13 Aug 2009 14:39:22 -0400
From: Chuck Lever <chuck.lever@...cle.com>
To: Joe Perches <joe@...ches.com>
Cc: Brian Haley <brian.haley@...com>, Jens Rosenboom <jens@...one.net>,
Linux Network Developers <netdev@...r.kernel.org>
Subject: Re: [RFC] ipv6: Change %pI6 format to output compacted addresses?
On Aug 13, 2009, at 2:21 PM, Joe Perches wrote:
> On Thu, 2009-08-13 at 14:15 -0400, Chuck Lever wrote:
>> On Aug 13, 2009, at 2:10 PM, Joe Perches wrote:
>>> The patch allows "%p6ic" for compressed and "%p6ic4" for compressed
>>> with ipv4 last u32.
>>
>> Why do these need to be separate?
>
> Just an option.
> I think it possible somebody will want "1::" instead of "1::0.0.0.0"
Hrm.
Do you have a use case? Really, it's pretty easy to tell when the
mapped v4 presentation format should be used. See
ipv6_addr_v4mapped(). Otherwise the mapped v4 presentation format
should never be used.
A problem with the existing %p[iI] implementation is that each call
site has to have logic that figures out the address family of the
address before calling sprintf(). This makes it difficult to use this
facility with, for example, debugging messages, since you have to add
address family detection logic at every debugging message call site.
Lots of clutter and duplicated code.
With %p6ic4, each call site now has to see that it's an IPv6 address,
and then decide if the address is a mapped v4 address or not. It's
the same logic everywhere.
It seems to me it would be a lot more useful if we had a new %p6
formatter that handled all types of IPv6 addresses properly, the way
inet_ntop(3) does in user space. (Or even a new formatter that could
handle both address families).
--
Chuck Lever
chuck[dot]lever[at]oracle[dot]com
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists