[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <200909071925.17078.opurdila@ixiacom.com>
Date: Mon, 7 Sep 2009 19:25:16 +0300
From: Octavian Purdila <opurdila@...acom.com>
To: "Ilia K." <mail4ilia@...il.com>
Cc: David Miller <davem@...emloft.net>, netdev@...r.kernel.org
Subject: Re: multicast routing and multiple interfaces with same IP
On Monday 07 September 2009 18:35:41 you wrote:
> Hi,
> I'm attaching a new patch. The changes:
> mroute.h:
> - consistent name for interface index: vifc_lcl_ifindex
> - union of vifc_lcl_addr and vifc_lcl_ifindex since either one of them
> can be used
> ipmr.c:
> - case VIFF_USE_IFINDEX and case 0 had almost the same code, so using
> fall through and if to eliminate code duplication
>
Hi Ilia,
Looks good to me, but there are a couple of code style issues reported by
./scripts/checkpatch.pl.
Also, here:
>+ } else {
>+ dev = ip_dev_find(net, vifc->vifc_lcl_addr.s_addr);
>+ }
Usually no braces are used for single line statements in if/else.
tavi
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists