[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20090917130315.GA4157@kroah.com>
Date: Thu, 17 Sep 2009 06:03:15 -0700
From: Greg KH <greg@...ah.com>
To: David Miller <davem@...emloft.net>
Cc: netdev@...r.kernel.org, Charles.Li@...rel.Com, Choi@...ah.com,
David.Choi@...rel.Com, jgarzik@...hat.com, shemminger@...tta.com
Subject: Re: [PATCH] ks8851_ml ethernet network driver
On Wed, Sep 16, 2009 at 08:48:01PM -0700, David Miller wrote:
> From: Greg KH <greg@...ah.com>
> Date: Wed, 16 Sep 2009 19:38:36 -0700
>
> > From: Choi, David <David.Choi@...rel.Com>
> >
> > This is a network driver for the ks8851 16bit MLL ethernet device.
> >
> > Signed-off-by: David J. Choi <david.choi@...rel.com>
> > Signed-off-by: Greg Kroah-Hartman <gregkh@...e.de>
>
> This doesn't even build cleanly:
>
> drivers/net/ks8851_mll.c: In function ‘ks_inblk’:
> drivers/net/ks8851_mll.c:555: warning: cast from pointer to integer of different size
> drivers/net/ks8851_mll.c:558: warning: passing argument 1 of ‘_readw’ makes pointer from integer without a cast
> drivers/net/ks8851_mll.c: In function ‘ks_outblk’:
> drivers/net/ks8851_mll.c:571: warning: cast from pointer to integer of different size
> drivers/net/ks8851_mll.c:574: warning: passing argument 2 of ‘_writew’ makes pointer from integer without a cast
Ick, David Choi, what happened here?
> It also has a big "#define DEBUG" at the beginning of the driver.
>
> And it also has stuff like:
>
> +#define MALLOC(x) kmalloc(x, GFP_KERNEL)
>
> which actually decreases the readability of this driver.
>
> Please fix this up.
Sorry about that, I'll do a closer review next time before resubmitting.
David Choi, care to fix this, and the comments from Stephen up?
thanks,
greg k-h
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists