[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1254949168-12404-1-git-send-email-nicolas.2p.debian@free.fr>
Date: Wed, 7 Oct 2009 22:59:27 +0200
From: Nicolas de Pesloüan
<nicolas.2p.debian@...e.fr>
To: fubar@...ibm.com, davem@...emloft.net
Cc: netdev@...r.kernel.org, bonding-devel@...ts.sourceforge.net
Subject: [PATCH netnext-2.6] bonding: fix a parameter name in error message
When parsing module parameters, bond_check_params() erroneously use 'xor_mode'
as the name of a module parameter in an error message.
The right name for this parameter is 'xmit_hash_policy'.
Signed-off-by: Nicolas de Pesloüan <nicolas.2p.debian@...e.fr>
---
drivers/net/bonding/bond_main.c | 3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/drivers/net/bonding/bond_main.c b/drivers/net/bonding/bond_main.c
index 69c5b15..20dc5a2 100644
--- a/drivers/net/bonding/bond_main.c
+++ b/drivers/net/bonding/bond_main.c
@@ -4665,7 +4665,8 @@ static int bond_check_params(struct bond_params *params)
if ((bond_mode != BOND_MODE_XOR) &&
(bond_mode != BOND_MODE_8023AD)) {
pr_info(DRV_NAME
- ": xor_mode param is irrelevant in mode %s\n",
+ ": xmit_hash_policy param is irrelevant in"
+ " mode %s\n",
bond_mode_name(bond_mode));
} else {
xmit_hashtype = bond_parse_parm(xmit_hash_policy,
--
1.6.3.3
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists