[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <OFDF2F06F9.1F8246ED-ON65257688.0030E506-65257688.00310B14@in.ibm.com>
Date: Thu, 10 Dec 2009 14:36:46 +0530
From: Krishna Kumar2 <krkumar2@...ibm.com>
To: "Ilpo Järvinen" <ilpo.jarvinen@...sinki.fi>
Cc: davem@...emloft.net, netdev@...r.kernel.org
Subject: Re: [PATCH 2/3] tcp: Remove unrequired operations in tcp_push()
"Ilpo Järvinen" <ilpo.jarvinen@...sinki.fi> wrote on 12/10/2009 01:40:51
PM:
> Re: [PATCH 2/3] tcp: Remove unrequired operations in tcp_push()
>
>
> > static inline void tcp_push(struct sock *sk, int flags, int mss_now,
> > int nonagle)
> > {
> > - struct tcp_sock *tp = tcp_sk(sk);
> > -
> > if (tcp_send_head(sk)) {
> > - struct sk_buff *skb = tcp_write_queue_tail(sk);
> > - if (!(flags & MSG_MORE) || forced_push(tp))
> > + struct tcp_sock *tp = tcp_sk(sk);
> > +
> > + if (!(flags & MSG_MORE) || forced_push(tp)) {
> > + struct sk_buff *skb = tcp_write_queue_tail(sk);
> > +
> > tcp_mark_push(tp, skb);
>
> I suppose one could kill the temporary variable completely then?
I did consider that, but kept it this way for readability reasons.
Should I change it?
Thanks,
- KK
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists