[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.DEB.2.00.0912101224270.7024@wel-95.cs.helsinki.fi>
Date: Thu, 10 Dec 2009 12:26:59 +0200 (EET)
From: "Ilpo Järvinen" <ilpo.jarvinen@...sinki.fi>
To: Krishna Kumar2 <krkumar2@...ibm.com>
cc: David Miller <davem@...emloft.net>, Netdev <netdev@...r.kernel.org>
Subject: Re: [PATCH 2/3] tcp: Remove unrequired operations in tcp_push()
On Thu, 10 Dec 2009, Krishna Kumar2 wrote:
> "Ilpo Järvinen" <ilpo.jarvinen@...sinki.fi> wrote on 12/10/2009 01:40:51
> PM:
>
> > Re: [PATCH 2/3] tcp: Remove unrequired operations in tcp_push()
> >
> >
> > > static inline void tcp_push(struct sock *sk, int flags, int mss_now,
> > > int nonagle)
> > > {
> > > - struct tcp_sock *tp = tcp_sk(sk);
> > > -
> > > if (tcp_send_head(sk)) {
> > > - struct sk_buff *skb = tcp_write_queue_tail(sk);
> > > - if (!(flags & MSG_MORE) || forced_push(tp))
> > > + struct tcp_sock *tp = tcp_sk(sk);
> > > +
> > > + if (!(flags & MSG_MORE) || forced_push(tp)) {
> > > + struct sk_buff *skb = tcp_write_queue_tail(sk);
> > > +
> > > tcp_mark_push(tp, skb);
> >
> > I suppose one could kill the temporary variable completely then?
>
> I did consider that, but kept it this way for readability reasons.
> Should I change it?
Honestly that doesn't look that fuzzy code even if you'd stick it into the
tcp_mark_push line (nor should be even close to 80 limit). ...I was even
thinking of getting totally rid of that skb arg of tcp_mark_push as I
think it's always tcp_write_queue_tail(sk) that is put there.
--
i.
Powered by blists - more mailing lists