lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 16 Dec 2009 17:15:12 +0100
From:	Sjur Brændeland <sjur.brandeland@...ricsson.com>
To:	"stefano babic" <stefano.babic@...ic.homelinux.org>
Cc:	<netdev@...r.kernel.org>, <randy.dunlap@...cle.com>,
	"Kim Lilliestierna XX" <kim.xx.lilliestierna@...ricsson.com>,
	"Christian Bejram" <christian.bejram@...ricsson.com>,
	"Daniel Martensson" <daniel.martensson@...ricsson.com>
Subject: RE: [RFC PATCH v3  3/8] CAIF Protocol Stack

stefano babic wrote:
> sjur.brandeland@...ricsson.com wrote:
>> diff --git a/include/net/caif/caif_chr.h
>> b/include/net/caif/caif_chr.h 
>> new file mode 100644 index 0000000..ebd89f8
>> --- /dev/null
>> +++ b/include/net/caif/caif_chr.h
> 
> Only a question of taste, but there is no chr device anymore, maybe
> another name for the file should be more appropriate.

Yes, I'll rename to caif_dev.h

>> +struct caif_service_config;
>> +enum cf_chr_dev_type {
...
>> +extern int serial_use_stx;
>> +extern int (*netdev_mgmt_func) (int action, union caif_action
>> *param); +int caifdev_phy_reg(struct layer *phyif, struct
>> cfcnfg_phy_mgmt *mgmt); +int caifdev_phy_instanciate(struct
>> cfcnfg_phy_config *phy_config); +int caifdev_phy_register(struct
>> layer *phyif, +			 enum cfcnfg_phy_type phy_type,
>> +			 enum cfcnfg_phy_preference phy_pref);
>> +int caifdev_phy_unregister(struct layer *phyif);
>> +int caifdev_phy_loop_register(struct layer *phyif,
>> +			      enum cfcnfg_phy_type phy_type);
>> +int caifdev_phy_spi_xmitlen(struct cfspil *layr);
>> +struct cfpkt *caifdev_phy_spi_getxmitpkt(struct cfspil *layr);
> 
> All these functions seem obsolete.
> 
>> +int caif_register_chrdev(int (*chrdev_mgmt)
>> +			(int action, union caif_action *param));
>> +void caif_unregister_chrdev(void);
> 
> Obsolete, too.

Yes, I agree. This header file needs some serious cleanup.
I'll rename it to caif_dev.h add config_util and strip it down 
to something like this:
[snip]
struct caif_service_config;
int caifdev_adapt_register(struct caif_channel_config *config,
			   struct layer *adap_layer);
int caifdev_adapt_unregister(struct layer *adap_layer);
struct cfcnfg *get_caif_conf(void);
void caif_register_ioctl(int (*ioctl)(unsigned int cmd,
				      unsigned long arg,
				      bool));
int caif_ioctl(unsigned int cmd, unsigned long arg, bool from_use_land);
void caif_unregister_netdev(void);
int channel_config_2_link_param(struct cfcnfg *cnfg,
				struct caif_channel_config *s,
				struct cfctrl_link_param *l);


>> diff --git a/include/net/caif/caif_config_util.h
... 
> Do we need an extra-header only to set the prototype of a single
> function ? Probably can we move it into another header file.

You're right, I'll move this into caif_dev.h (see above). 

BR/Sjur
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ