[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <201003112207.o2BM7o2e013489@imap1.linux-foundation.org>
Date: Thu, 11 Mar 2010 14:07:50 -0800
From: akpm@...ux-foundation.org
To: davem@...emloft.net
Cc: netdev@...r.kernel.org, akpm@...ux-foundation.org,
akinobu.mita@...il.com, chas@....nrl.navy.mil
Subject: [patch 2/5] atm: use for_each_set_bit()
From: Akinobu Mita <akinobu.mita@...il.com>
Replace open-coded loop with for_each_set_bit().
Signed-off-by: Akinobu Mita <akinobu.mita@...il.com>
Cc: Chas Williams <chas@....nrl.navy.mil>
Signed-off-by: Andrew Morton <akpm@...ux-foundation.org>
---
drivers/atm/lanai.c | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)
diff -puN drivers/atm/lanai.c~atm-use-for_each_set_bit drivers/atm/lanai.c
--- a/drivers/atm/lanai.c~atm-use-for_each_set_bit
+++ a/drivers/atm/lanai.c
@@ -306,11 +306,10 @@ static void vci_bitfield_iterate(struct
const unsigned long *lp,
void (*func)(struct lanai_dev *,vci_t vci))
{
- vci_t vci = find_first_bit(lp, NUM_VCI);
- while (vci < NUM_VCI) {
+ vci_t vci;
+
+ for_each_set_bit(vci, lp, NUM_VCI)
func(lanai, vci);
- vci = find_next_bit(lp, NUM_VCI, vci + 1);
- }
}
/* -------------------- BUFFER UTILITIES: */
_
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists