[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4BCAE509.9000209@Calva.COM>
Date: Sun, 18 Apr 2010 12:55:05 +0200
From: John Hughes <john@...va.COM>
To: Andrew Hendry <andrew.hendry@...il.com>
CC: netdev@...r.kernel.org
Subject: Re: [PATCH 1/6] X25: Use identifiers for X25 to device interface
Andrew Hendry wrote:
> Use identifiers in x25_device.h instead of magic numbers for X25 layer 3 to device interface.
> Also fixed checkpatch notes on updated code.
> [...]
>
> -First Byte = 0x00
> +First Byte = 0x00 (X25_IFACE_DATA)
> [...]
> +
> +enum {
> + X25_IFACE_DATA,
> + X25_IFACE_CONNECT,
> + X25_IFACE_DISCONNECT,
> + X25_IFACE_PARAMS
> +};
>
Shouldn't you use explicit values here?
enum {
X25_IFACE_DATA = 0x00, /* explicit value for ABI stability */
...
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists