lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Thu, 1 Jul 2010 15:40:38 -0600
From:	"Tantilov, Emil S" <emil.s.tantilov@...el.com>
To:	Andrew Morton <akpm@...ux-foundation.org>,
	"netdev@...r.kernel.org" <netdev@...r.kernel.org>,
	"Kirsher, Jeffrey T" <jeffrey.t.kirsher@...el.com>,
	"Brandeburg, Jesse" <jesse.brandeburg@...el.com>,
	"Allan, Bruce W" <bruce.w.allan@...el.com>,
	"Duyck, Alexander H" <alexander.h.duyck@...el.com>,
	"Waskiewicz Jr, Peter P" <peter.p.waskiewicz.jr@...el.com>
CC:	"bugzilla-daemon@...zilla.kernel.org" 
	<bugzilla-daemon@...zilla.kernel.org>,
	"bugme-daemon@...zilla.kernel.org" <bugme-daemon@...zilla.kernel.org>,
	"lukas.valach@...nam.sk" <lukas.valach@...nam.sk>
Subject: RE: [Bugme-new] [Bug 16293] New: 82545GM in newest kernel not
 working.

Andrew Morton wrote:
> (switched to email.  Please respond via emailed reply-to-all, not via
> the bugzilla web interface).
> 
> On Fri, 25 Jun 2010 17:48:43 GMT
> bugzilla-daemon@...zilla.kernel.org wrote:
> 
>> https://bugzilla.kernel.org/show_bug.cgi?id=16293
>> 
>>            Summary: 82545GM in newest kernel not working.           
>>            Product: Drivers Version: 2.5
>>     Kernel Version: 2.6.32.15
>>           Platform: All
>>         OS/Version: Linux
>>               Tree: Mainline
>>             Status: NEW
>>           Severity: high
>>           Priority: P1
>>          Component: Network
>>         AssignedTo: drivers_network@...nel-bugs.osdl.org
>>         ReportedBy: lukas.valach@...nam.sk
>>         Regression: No
>> 
>> 
>> lspci:
>> 
>> 01:01.0 Ethernet controller: Intel Corporation 82545GM Gigabit
>> Ethernet Controller (rev 04) 01:02.0 Ethernet controller: Intel
>> Corporation 82545GM Gigabit Ethernet Controller (rev 04) 02:01.0
>> Ethernet controller: Intel Corporation 82546GB Gigabit Ethernet
>> Controller (rev 03) 02:01.1 Ethernet controller: Intel Corporation
>> 82546GB Gigabit Ethernet Controller (rev 03)  
>> 
>> All interface are correctly configured. In kernel <2.6.26 get all
>> OK, in newest kernels network interfaces are not working. Problem is
>> in driver e1000. Tested on 2.6.31,2.6.32,2.6.34 and 2.6.35rc.
> 
> A somewhat old e1000 regression?

I ran a quick test on net-next with 82545GM NICs and was able to pass traffic without issues.

Would it be possible to get more information about the system/setup:

1. full lspci output (lspci -vvv)
2. ethtool -i ethX
3. ethtool -d ethX
4. ethtool -e ethX
5. dmesg  - after loading the driver and configuring the interfaces
6. kernel config

A better description of the issue would help as well. What exactly fails - ping?

Thanks,
Emil--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists