[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <201007081541.57685.arnd@arndb.de>
Date: Thu, 8 Jul 2010 15:41:57 +0200
From: Arnd Bergmann <arnd@...db.de>
To: Stefan Assmann <sassmann@...hat.com>
Cc: netdev <netdev@...r.kernel.org>, e1000-devel@...ts.sourceforge.net,
"Duyck, Alexander H" <alexander.h.duyck@...el.com>,
gregory.v.rose@...el.com, jeffrey.t.kirsher@...el.com,
Andy Gospodarek <gospo@...hat.com>
Subject: Re: [PATCH] igbvf: avoid name clash between PF and VF
On Wednesday 30 June 2010, Stefan Assmann wrote:
> diff --git a/drivers/net/igbvf/netdev.c b/drivers/net/igbvf/netdev.c
> index 5e2b2a8..2fb665b 100644
> --- a/drivers/net/igbvf/netdev.c
> +++ b/drivers/net/igbvf/netdev.c
> @@ -2787,7 +2787,7 @@ static int __devinit igbvf_probe(struct pci_dev *pdev,
> netif_carrier_off(netdev);
> netif_stop_queue(netdev);
>
> - strcpy(netdev->name, "eth%d");
> + strcpy(netdev->name, "veth%d");
> err = register_netdev(netdev);
> if (err)
> goto err_hw_init;
Note that 'veth' is the name used for a virtual ethernet pair by
drivers/net/veth.c. If a variant of your patch gets applied, it would
probably be useful to use a different naming scheme to avoid confusion
with the veth driver.
Arnd
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists