lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Fri, 1 Oct 2010 02:39:21 +0300
From:	Sami Farin <hvtaifwkbgefbaei@...il.com>
To:	"Tantilov, Emil S" <emil.s.tantilov@...el.com>,
	Sami Farin <hvtaifwkbgefbaei@...il.com>,
	linux-kernel@...r.kernel.org, e1000-devel@...ts.sourceforge.net,
	netdev@...r.kernel.org
Subject: Re: [E1000-devel] Something wrong with tx/rx/sg/gso with dhclient
 etc (Was: Linux 2.6.35.6/e1000e does not receive replies  from DHCP server,
 2.6.33 works)

On Thu, Sep 30, 2010 at 12:44:17 +0300, Sami Farin wrote:
> On Wed, Sep 29, 2010 at 17:40:08 -0600, Tantilov, Emil S wrote:
> > Sami Farin wrote:
> > > False alarm, 2.6.35.6+latest git e1000e does not work any better.
> > > I was just lucky.
> > 
> > Is your `latest git` from Linus or net-next tree? 
> 
> Linus.
> 
> >All of our latest patches go into net-next, so if you haven't already - give it a try and see if it resolves your issue.
> 
> Maybe later =)

I now tried net-next 6d0722a2cec2c23db3b0855ff8bb433175a16b44, it works fine,
with ethtool -K tx/rx on and off.
I used the same .config as with 2.6.35.6 (make oldconfig).
I retested 2.6.33.7, it's still okay.

And unfortunately 2.6.35.6 did not work very well after rebooting,
I had to waste a lot of time playing with -K tx off rx off, -K tx on rx on, etc.
Before it started working, eth0 had interrupts occurring only on CPU0.
CPU1 started getting some usage only after dhclient started working..
Probably irrelevant, but I am running out of ideas.
I have tried e1000e param IntMode 0, 1, 2, no luck.

-- 
Do what you love because life is too short for anything else.

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists