lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 10 Nov 2010 19:19:38 -0800
From:	Joe Perches <joe@...ches.com>
To:	Casey Leedom <leedom@...lsio.com>
Cc:	netdev@...r.kernel.org, davem@...emloft.net
Subject: Re: [PATCH 01/10] cxgb4vf: minor comment/symbolic name cleanup.

On Wed, 2010-11-10 at 18:04 -0800, Casey Leedom wrote:
> Minor cleanup of comments and symbolic constant names for clarity.
> diff --git a/drivers/net/cxgb4vf/cxgb4vf_main.c b/drivers/net/cxgb4vf/cxgb4vf_main.c
> index 6de5e2e..f5259a1 100644
> --- a/drivers/net/cxgb4vf/cxgb4vf_main.c
> +++ b/drivers/net/cxgb4vf/cxgb4vf_main.c
> @@ -280,7 +280,7 @@ static void name_msix_vecs(struct adapter *adapter)
>  		const struct port_info *pi = netdev_priv(dev);
>  		int qs, msi;
>  
> -		for (qs = 0, msi = MSIX_NIQFLINT;
> +		for (qs = 0, msi = MSIX_IQFLINT;
>  		     qs < pi->nqsets;
>  		     qs++, msi++) {

This for now fits on a single line.

> diff --git a/drivers/net/cxgb4vf/t4vf_hw.c b/drivers/net/cxgb4vf/t4vf_hw.c
> index ea1c123..2180181 100644
> --- a/drivers/net/cxgb4vf/t4vf_hw.c
> +++ b/drivers/net/cxgb4vf/t4vf_hw.c
> @@ -1257,7 +1257,7 @@ int t4vf_eth_eq_free(struct adapter *adapter, unsigned int eqid)
>   */
>  int t4vf_handle_fw_rpl(struct adapter *adapter, const __be64 *rpl)
> -	struct fw_cmd_hdr *cmd_hdr = (struct fw_cmd_hdr *)rpl;
> +	const struct fw_cmd_hdr *cmd_hdr = (const struct fw_cmd_hdr *)rpl;
> @@ -1265,7 +1265,7 @@ int t4vf_handle_fw_rpl(struct adapter *adapter, const __be64 *rpl)
> -		const struct fw_port_cmd *port_cmd = (void *)rpl;
> +		const struct fw_port_cmd *port_cmd = (const void *)rpl;

might be better to have a consistent casting style.
1st uses a direct cast, 2nd an implicit one.

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ