[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20101231092543.GA7809@ff.dom.local>
Date: Fri, 31 Dec 2010 09:25:44 +0000
From: Jarek Poplawski <jarkao2@...il.com>
To: John Fastabend <john.r.fastabend@...el.com>
Cc: davem@...emloft.net, netdev@...r.kernel.org, hadi@...erus.ca,
shemminger@...tta.com, tgraf@...radead.org, eric.dumazet@...il.com,
bhutchings@...arflare.com, nhorman@...driver.com
Subject: Re: [net-next-2.6 PATCH v2 3/3] net_sched: implement a root
container qdisc sch_mclass
On 2010-12-21 20:29, John Fastabend wrote:
> This implements a mclass 'multi-class' queueing discipline that by
> default creates multiple mq qdisc's one for each traffic class. Each
> mq qdisc then owns a range of queues per the netdev_tc_txq mappings.
Btw, you could also consider better name (mqprio?) because there're
many 'multi-class' queueing disciplines around.
> +static int mclass_parse_opt(struct net_device *dev, struct tc_mclass_qopt *qopt)
> +{
> + int i, j;
> +
> + /* Verify TC offset and count are sane */
if (qopt->num_tc > TC_MAX_QUEUE) ?
return -EINVAL;
> + for (i = 0; i < qopt->num_tc; i++) {
> + int last = qopt->offset[i] + qopt->count[i];
> + if (last > dev->num_tx_queues)
if (last >= dev->num_tx_queues) ?
> + return -EINVAL;
> + for (j = i + 1; j < qopt->num_tc; j++) {
> + if (last > qopt->offset[j])
if (last >= qopt->offset[j]) ?
Jarek P.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists