[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4D2836BB.6000600@gmail.com>
Date: Sat, 08 Jan 2011 11:04:43 +0100
From: Jarek Poplawski <jarkao2@...il.com>
To: David Miller <davem@...emloft.net>
CC: xiaosuo@...il.com, paulus@...ba.org, harvey.harrison@...il.com,
linux-ppp@...r.kernel.org, netdev@...r.kernel.org
Subject: Re: [PATCH v2] net: ppp: use {get,put}_unaligned_be{16,32}
David Miller wrote:
> From: Changli Gao <xiaosuo@...il.com>
> Date: Sat, 8 Jan 2011 08:43:01 +0800
>
>> On Fri, Jan 7, 2011 at 11:01 AM, Paul Mackerras <paulus@...ba.org> wrote:
>>> On Fri, Jan 07, 2011 at 07:37:36AM +0800, Changli Gao wrote:
>>>
>>>> Signed-off-by: Changli Gao <xiaosuo@...il.com>
>>>
>>> This patch description is inadequate. It should tell us why you are
>>> making this change. Does it result in smaller and/or faster code, and
>>> if so by how much on what sort of machine? Do you think it makes the
>>> code clearer? (I don't.) Or is there some other motivation for this?
>>>
>>
>> Good designed APIs always make code clearer, smaller and faster. It is
>> obvious enough I think.
>
> I have to say that every time I go read the header parsing code in the
> PPP driver, I absolutely regret it.
>
> And Changli's patch fixes some of the readability problems.
Just for the record: I agree with Paul that current code is more readable.
This code still requires thinking about specific bytes and the patch mixes
it only with word access.
Jarek P.
> @@ -395,16 +396,14 @@ mppe_compress(void *arg, unsigned char *ibuf, unsigned char *obuf,
> */
> obuf[0] = PPP_ADDRESS(ibuf);
> obuf[1] = PPP_CONTROL(ibuf);
> - obuf[2] = PPP_COMP >> 8; /* isize + MPPE_OVHD + 1 */
> - obuf[3] = PPP_COMP; /* isize + MPPE_OVHD + 2 */
> + put_unaligned_be16(PPP_COMP, obuf + 2);
> obuf += PPP_HDRLEN;
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists