[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1294907081.4114.35.camel@Joe-Laptop>
Date: Thu, 13 Jan 2011 00:24:41 -0800
From: Joe Perches <joe@...ches.com>
To: Tobias Klauser <tklauser@...tanz.ch>
Cc: David Miller <davem@...emloft.net>, cmetcalf@...era.com,
netdev@...r.kernel.org
Subject: Re: [PATCH net-next-2.6] etherdevice.h: Add is_unicast_ether_addr
function
On Thu, 2011-01-13 at 09:14 +0100, Tobias Klauser wrote:
> >From a check for !is_multicast_ether_addr it is not always obvious that
> we're checking for a unicast address. So add this helper function to
> make those code paths easier to read.
> include/linux/etherdevice.h | 11 +++++++++++
[]
> /**
> + * is_unicast_ether_addr - Determine if the Ethernet address is unicast
> + * @addr: Pointer to a six-byte array containing the Ethernet address
> + *
> + * Return true if the address is a unicast address.
> + */
> +static inline int is_unicast_ether_addr(const u8 *addr)
> +{
> + return !is_multicast_ether_addr(addr);
> +}
Can't you simply use is_valid_ether_addr?
I can't think of much reason that a new function for
!multicast without the !is_zero is needed.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists